<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.kawowo.com/xmlrpc.php">

<title>Top versus bottom contest as Sports Club Villa Jogoo entertains Masavu in Masaka</title>

<!-- This site is optimized with the Yoast SEO plugin v7.0.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Current Uganda Premier League table leaders Sports Club Villa Jogoo eye consolidation of their status when they entertain Masavu at the Masaka Recreational Stadium on Wednesday."/>
<link rel="canonical" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Top versus bottom contest as Sports Club Villa Jogoo entertains Masavu in Masaka" />
<meta property="og:description" content="Current Uganda Premier League table leaders Sports Club Villa Jogoo eye consolidation of their status when they entertain Masavu at the Masaka Recreational Stadium on Wednesday." />
<meta property="og:url" content="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/" />
<meta property="og:site_name" content="Kawowo Sports" />
<meta property="article:publisher" content="https://www.facebook.com/kawowosports" />
<meta property="article:author" content="https://www.facebook.com/isabirye.david.96" />
<meta property="article:section" content="Football" />
<meta property="article:published_time" content="2018-03-14T01:55:49+03:00" />
<meta property="og:image" content="https://www.kawowo.com/wp-content/uploads/2018/03/jb-godfrey-lwesibawa-sc-villa.jpg" />
<meta property="og:image:secure_url" content="https://www.kawowo.com/wp-content/uploads/2018/03/jb-godfrey-lwesibawa-sc-villa.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="600" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Current Uganda Premier League table leaders Sports Club Villa Jogoo eye consolidation of their status when they entertain Masavu at the Masaka Recreational Stadium on Wednesday." />
<meta name="twitter:title" content="Top versus bottom contest as Sports Club Villa Jogoo entertains Masavu in Masaka" />
<meta name="twitter:site" content="@KawowoSports" />
<meta name="twitter:image" content="https://www.kawowo.com/wp-content/uploads/2018/03/jb-godfrey-lwesibawa-sc-villa.jpg" />
<meta name="twitter:creator" content="@IsabiryeDavid" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.kawowo.com\/","sameAs":["https:\/\/www.facebook.com\/kawowosports","https:\/\/www.instagram.com\/kawowosports\/","https:\/\/www.youtube.com\/c\/Kawowo","https:\/\/twitter.com\/KawowoSports"],"@id":"#organization","name":"Kawowo Sports","logo":"http:\/\/www.kawowo.com\/wp-content\/uploads\/2016\/11\/kww1.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Feed" href="https://www.kawowo.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Comments Feed" href="https://www.kawowo.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Top versus bottom contest as Sports Club Villa Jogoo entertains Masavu in Masaka Comments Feed" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.0.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_track_user = true;
	var disableStr = 'ga-disable-UA-20862137-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-20862137-4', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you\'re not being tracked. ");
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
		})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.kawowo.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='media-credit-css'  href='https://www.kawowo.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=3.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.kawowo.com/wp-includes/css/dashicons.min.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-general-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/css/sportspress.css?ver=2.5.10' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-icons-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/css/icons.css?ver=2.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-league-menu-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-league-menu/css/sportspress-league-menu.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-event-statistics-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-match-stats/css/sportspress-match-stats.css?ver=2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-scoreboard-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-scoreboard/css/sportspress-scoreboard.css?ver=2.5' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-scoreboard-ltr-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-scoreboard/css/sportspress-scoreboard-ltr.css?ver=2.5' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-sponsors-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-sponsors/css/sportspress-sponsors.css?ver=2.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-timelines-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-timelines/css/sportspress-timelines.css?ver=2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-tournaments-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/css/sportspress-tournaments.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-tournaments-ltr-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/css/sportspress-tournaments-ltr.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-bracket-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/css/jquery.bracket.min.css?ver=0.11.0' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-twitter-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-twitter/css/sportspress-twitter.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-user-scores-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-user-scores/css/sportspress-user-scores.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.kawowo.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.0.13' type='text/css' media='all' />
<link rel='stylesheet' id='kawowo-style-css'  href='https://www.kawowo.com/wp-content/themes/kawowo-sports/style.css?ver=4.9.4' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.kawowo.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' />
<style type="text/css"></style><script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.kawowo.com","track_download_as":"pageview","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.0.4'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-facebook/js/sportspress-facebook-sdk.js?ver=2.11'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/js/jquery.bracket.min.js?ver=0.11.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"10","ajax_url":"https:\/\/www.kawowo.com\/wp-admin\/admin-ajax.php","action":"update_views_ajax","ID":"91773","token":"2060c63563"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp.js?ver=4.0.13'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=5.9'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=5.9'></script>
<link rel='https://api.w.org/' href='https://www.kawowo.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.kawowo.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.kawowo.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.4" />
<meta name="generator" content="SportsPress 2.5.10" />
<meta name="generator" content="SportsPress Pro 2.5.10" />
<link rel='shortlink' href='https://goo.gl/ecTpu4' />
<link rel="alternate" type="application/json+oembed" href="https://www.kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kawowo.com%2F2018%2F03%2F14%2Ftop-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kawowo.com%2F2018%2F03%2F14%2Ftop-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.10 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 {  margin: 0 auto; }
	.g-2 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

			<meta property="fb:pages" content="145227195529292" />
							<meta property="ia:markup_url" content="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?ia_markup=1" />
				
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css">
		#secondary .widget:nth-of-type(3n+1), #secondary .widget:nth-of-type(3n+1) .widget-title span {background-color:#ffffff;}
		#secondary .widget:nth-of-type(3n+2), #secondary .widget:nth-of-type(3n+2) .widget-title span {background-color:#ffffff;}
		#secondary .widget:nth-of-type(3n+3), #secondary .widget:nth-of-type(3n+3) .widget-title span {background-color:#ffffff;}
		.home, .archive, .search, .home .slick-prev:after, .home .slick-next:after, .home #secondary .widget_social_media_icons_widget_by_fat li, .archive #secondary .widget_social_media_icons_widget_by_fat li, .search #secondary .widget_social_media_icons_widget_by_fat li, .home #secondary .widget.widget_mc4wp_form_widget, .home #secondary .widget.widget_mc4wp_form_widget .widget-title span, .home #bottom-widget .widget-title span, .home #top-widget .widget-title span, .archive #secondary .widget.widget_mc4wp_form_widget, .archive #secondary .widget.widget_mc4wp_form_widget .widget-title span, .archive #bottom-widget .widget-title span, .archive #top-widget .widget-title span, .search #secondary .widget.widget_mc4wp_form_widget, .search #secondary .widget.widget_mc4wp_form_widget .widget-title span, .search #bottom-widget .widget-title span, .search #top-widget .widget-title span {background-color: #f5f5f5;}
						svg:hover,a svg:hover,.kawowo-author-social-icons a:hover svg {fill: #ff0000;}
		button,input[type="button"],input[type="reset"],input[type="submit"],.navbar-navigation .current_page_item > a:after,.navbar-navigation .current-menu-item > a:after,.navbar-navigation .current_page_ancestor > a:after,.navbar-navigation .current-menu-ancestor > a:after {border: 1px solid #ff0000;}
		button:hover,input[type="button"]:hover,input[type="reset"]:hover,input[type="submit"]:hover,a:hover,a:focus,a:active,.navbar-navigation ul ul .current_page_item > a,.navbar-navigation ul ul .current-menu-item > a,.navbar-navigation ul ul .current_page_ancestor > a,.navbar-navigation ul ul .current-menu-ancestor > a,.navbar-navigation a:hover,.main-navigation ul .current_page_item > a,
		.main-navigation ul .current-menu-item > a,.main-navigation ul .current_page_ancestor > a,.main-navigation ul .current-menu-ancestor > a,.main-navigation ul .current_page_item > .expand-submenu,.main-navigation ul .current-menu-item > .expand-submenu,.main-navigation ul .current_page_ancestor > .expand-submenu,.main-navigation ul .current-menu-ancestor > .expand-submenu,.widget_nav_menu ul .current_page_item > a,.widget_nav_menu ul .current-menu-item > a,.widget_nav_menu ul .current_page_ancestor > a,.widget_nav_menu ul .current-menu-ancestor > a,.widget_nav_menu ul .current_page_item > .expand-submenu,.widget_nav_menu ul .current-menu-item > .expand-submenu,.widget_nav_menu ul .current_page_ancestor > .expand-submenu,.widget_nav_menu ul .current-menu-ancestor > .expand-submenu,.nav-links a:hover > .kawowo-next-article-title,.nav-links a:hover > .kawowo-previous-article-title,.nav-links a:hover > .kawowo-next-article,.nav-links a:hover > .kawowo-previous-article,.main-navigation .expand-submenu:hover,.widget_nav_menu .expand-submenu:hover,.main-navigation a:hover,.widget_nav_menu a:hover,.nav-social a:hover svg,.left-nav-social a:hover svg {color: #ff0000;}
		.kawowo-search-panel .kawowo-search-panel-close:hover,
		.menu-toggle:hover,
		.search-toggle:hover,
		button,
		input[type="button"],
		input[type="reset"],
		input[type="submit"] {background-color: #ff0000;}
		.left-sidebar-close:hover svg line {stroke: #ff0000;}
		@media screen and (min-width: 992px )  {
		.menu-logo {float:left;}
		.navbar-navigation ul, .nav-social {display:block;}
		/*.kawowo-featured-slider, .kawowo-featured-slider .featured-image, .kawowo-featured-slider .no-featured-image {height:500px;}*/
		}
		</style>
		<link rel="amphtml" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/amp/"><link rel="icon" href="https://www.kawowo.com/wp-content/uploads/2016/11/favicon-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg" />
<meta name="msapplication-TileImage" content="https://www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg" />
</head>

<body class="post-template-default single single-post postid-91773 single-format-standard wp-custom-logo group-blog">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">

				<nav id="top-navigation" class="navbar-navigation" role="navigation">

					<button id="left-navbar-toggle" class="menu-toggle" aria-controls="left-sidebar" aria-expanded="false"><span class="screen-reader-text">Menu</span><svg><path d="M3 6h18v2.016h-18v-2.016zM3 12.984v-1.969h18v1.969h-18zM3 18v-2.016h18v2.016h-18z"></path></svg></button>
					<button id="navbar-search-toggle" class="search-toggle" aria-controls="search-panel" aria-expanded="false"><span class="screen-reader-text">Search</span><svg><path d="M9.516 14.016q1.875 0 3.188-1.313t1.313-3.188-1.313-3.188-3.188-1.313-3.188 1.313-1.313 3.188 1.313 3.188 3.188 1.313zM15.516 14.016l4.969 4.969-1.5 1.5-4.969-4.969v-0.797l-0.281-0.281q-1.781 1.547-4.219 1.547-2.719 0-4.617-1.875t-1.898-4.594 1.898-4.617 4.617-1.898 4.594 1.898 1.875 4.617q0 2.438-1.547 4.219l0.281 0.281h0.797z"></path></svg></button>
					<div id="search-panel" class="kawowo-search-panel">
					    <button class="kawowo-search-panel-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button>
						<form role="search" method="get" class="search-form" action="https://www.kawowo.com/">
	<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field" placeholder="Type and hit enter" value="" name="s" title="Search for:" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
						<div id="menu-social-widget" class="widget-area menu-social-widget" role="complementary">
		<aside id="social_media_icons_widget_by_fat-3" class="widget widget_social_media_icons_widget_by_fat"><ul><li><a title="View kawowosports&#8217;s profile on Facebook" href="https://www.facebook.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Facebook</span><span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Twitter" href="https://twitter.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Twitter</span><span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></span></a></li><li><a title="View KawowoSports&#8217;s profile on Instagram" href="https://instagram.com/KawowoSports/" target="_blank"><span class="screen-reader-text">View KawowoSports&#8217;s profile on Instagram</span><span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></span></a></li><li><a title="View Kawowo&#8217;s profile on Google+" href="https://plus.google.com/u/0/+Kawowo/" target="_blank"><span class="screen-reader-text">View Kawowo&#8217;s profile on Google+</span><span><svg viewBox="0 0 36 28"><path d="M22.453 14.266q0 3.25-1.359 5.789t-3.875 3.969-5.766 1.43q-2.328 0-4.453-0.906t-3.656-2.438-2.438-3.656-0.906-4.453 0.906-4.453 2.438-3.656 3.656-2.438 4.453-0.906q4.469 0 7.672 3l-3.109 2.984q-1.828-1.766-4.562-1.766-1.922 0-3.555 0.969t-2.586 2.633-0.953 3.633 0.953 3.633 2.586 2.633 3.555 0.969q1.297 0 2.383-0.359t1.789-0.898 1.227-1.227 0.766-1.297 0.336-1.156h-6.5v-3.938h10.813q0.187 0.984 0.187 1.906zM36 12.359v3.281h-3.266v3.266h-3.281v-3.266h-3.266v-3.281h3.266v-3.266h3.281v3.266h3.266z"></path></svg></span></a></li></ul></aside>	</div><!-- #menu-social-widget -->
					<div class="menu-logo">
						<a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png" class="custom-logo" alt="Kawowo Sports" itemprop="logo" srcset="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png 888w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-480x135.png 480w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-768x216.png 768w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-722x203.png 722w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-300x84.png 300w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-128x36.png 128w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-32x9.png 32w" sizes="(max-width: 888px) 100vw, 888px" /></a>					</div>
						<div class="menu-mainmenu-container"><ul id="top-menu" class="menu"><li id="menu-item-42339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42339"><a href="https://www.kawowo.com">Home</a></li>
<li id="menu-item-42340" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42340"><a href="https://www.kawowo.com/football/">Football</a></li>
<li id="menu-item-42346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42346"><a href="https://www.kawowo.com/basketball/">Basketball</a></li>
<li id="menu-item-42347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42347"><a href="https://www.kawowo.com/rugby/">Rugby</a></li>
<li id="menu-item-42350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42350"><a href="https://www.kawowo.com/motorsport/">Motorsport</a></li>
<li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.kawowo.com/cricket/">Cricket</a></li>
<li id="menu-item-42348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42348"><a href="https://www.kawowo.com/athletics/">Athletics</a></li>
<li id="menu-item-42349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42349"><a href="https://www.kawowo.com/golf/">Golf</a></li>
<li id="menu-item-42345" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42345"><a>More</a><span class="expand-submenu" title="Expand">&#43;</span>
<ul class="sub-menu">
	<li id="menu-item-42351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42351"><a href="https://www.kawowo.com/pool/">Pool</a></li>
	<li id="menu-item-42343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42343"><a href="https://www.kawowo.com/weightlifting/">Weightlifting</a></li>
	<li id="menu-item-42344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42344"><a href="https://www.kawowo.com/volleyball/">Volleyball</a></li>
	<li id="menu-item-82243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82243"><a href="https://www.kawowo.com/chess/">Chess</a></li>
	<li id="menu-item-82244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82244"><a href="https://www.kawowo.com/others/">Others</a></li>
	<li id="menu-item-82245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82245"><a href="https://www.kawowo.com/boxing/">Boxing</a></li>
	<li id="menu-item-82246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82246"><a href="https://www.kawowo.com/cycling/">Cycling</a></li>
	<li id="menu-item-82247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82247"><a href="https://www.kawowo.com/hockey/">Hockey</a></li>
	<li id="menu-item-82248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82248"><a href="https://www.kawowo.com/lacrosse/">Lacrosse</a></li>
	<li id="menu-item-82249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82249"><a href="https://www.kawowo.com/live/">Live</a></li>
	<li id="menu-item-82251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82251"><a href="https://www.kawowo.com/rowing/">Rowing</a></li>
	<li id="menu-item-82250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82250"><a href="https://www.kawowo.com/netball/">Netball</a></li>
	<li id="menu-item-82252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82252"><a href="https://www.kawowo.com/swimming/">Swimming</a></li>
	<li id="menu-item-82253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82253"><a href="https://www.kawowo.com/tennis/">Tennis</a></li>
</ul>
</li>
<li id="menu-item-42352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42352"><a href="https://www.kawowo.com/opinion/">Op-eds</a></li>
<li id="menu-item-55773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55773"><a>STATS</a><span class="expand-submenu" title="Expand">&#43;</span>
<ul class="sub-menu">
	<li id="menu-item-55774" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55774"><a href="https://www.kawowo.com/table/2017-18-upl-table/">UPL Table Standings</a></li>
	<li id="menu-item-55783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55783"><a href="https://www.kawowo.com/calendar/results/">All Results</a></li>
	<li id="menu-item-55780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55780"><a href="https://www.kawowo.com/calendar/fixtures/">All Fixtures</a></li>
	<li id="menu-item-78030" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78030"><a href="https://www.kawowo.com/list/201718-uganda-premier-league-top-scorers/">UPL top scorers</a></li>
</ul>
</li>
</ul></div>		</nav><!-- #site-navigation -->

	    
	</header><!-- #masthead -->

	<div id="content" class="site-content container">
		<div class="row">
	<div id="top-ads-widget" class="widget-area col-xs-12" role="complementary">
	    <aside id="ajdg_bnnrwidgets-7" class="widget ajdg_bnnrwidgets"><div class="a-single a-1"><a class="gofollow" data-track="MSwwLDEsNjA=" href="https://goo.gl/khGb5V" target="_blank"> <img src="https://www.kawowo.com/wp-content/uploads/2018/01/kww_airtel_datablasta.gif" /></a></div></aside>	</div><!-- #top-widget -->
</div>
<div class="row">
		<div id="primary" class="content-area col-lg-8">
		<main id="main" class="site-main row" role="main">

		
			
<article id="post-91773" class="col-md-12 post-91773 post type-post status-publish format-standard has-post-thumbnail hentry category-football">
	<header class="entry-header row">
		<div class="single-header col-xs-12">
		<div class="category-list">
		<a href="https://www.kawowo.com/football/">Football</a>		</div>
		<h1 class="entry-title">Top versus bottom contest as Sports Club Villa Jogoo entertains Masavu in Masaka</h1>	</div>
		<div class="col-xs-12 col-sm-8 col-sm-push-4 col-md-9 col-md-push-3 col-lg-9 col-lg-push-3 col-xl-10 col-xl-push-2">
			<div class="kawowo-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-91773" class="share-facebook sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-91773" class="share-twitter sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=Top%20versus%20bottom%20contest%20as%20Sports%20Club%20Villa%20Jogoo%20entertains%20Masavu%20in%20Masaka https%3A%2F%2Fgoo.gl%2FecTpu4" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-91773" class="share-google-plus-1 sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-91773" class="share-linkedin sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div>			<div class="entry-meta">
				<span class="posted-on"><a href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/" rel="bookmark"><time class="entry-date published updated" datetime="2018-03-14T01:55:49+00:00">5 hours</time></a> ago</span><br/><span class="byline">  by <span class="author vcard"><a class="url fn n" href="https://www.kawowo.com/author/david/">David Isabirye</a></span></span>			</div><!-- .entry-meta -->
		</div>

		<div class='author-avatar-wrapper col-xs-12 col-sm-4 col-sm-pull-8 col-md-3 col-md-pull-9 col-xl-2 col-xl-pull-10'>
			<div class="author-avatar"><img alt='' src='https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></div><div class="kawowo-author-social-icons"><a href="https://twitter.com/IsabiryeDavid" title="Twitter" target="_blank"><span class="screen-reader-text">Twitter</span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></a><a href="https://www.facebook.com/isabirye.david.96" title="Facebook" target="_blank"><span class="screen-reader-text">Facebook</span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></a><a href="https://www.instagram.com/davidisabirye" title="Instagram" target="_blank"><span class="screen-reader-text">Instagram</span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></a></div>		</div>
	</header><!-- .entry-header -->
		<div class="row">

	<div class="entry-content col-xs-12 col-lg-10 col-lg-push-2">
		<p><strong>Uganda Premier League:</strong></p>
<ul>
<li>Wednesday, 14<sup>th</sup> March 2018</li>
<li>Sports Club Villa Jogoo Vs Masavu</li>
<li>At Masaka Recreational Stadium (4:30 p.m)</li>
</ul>
<p><strong>Current Uganda Premier League table leaders Sports Club Villa Jogoo eye consolidation of their status when they entertain Masavu at the Masaka Recreational Stadium on Wednesday.</strong></p>
<figure id="attachment_91013" style="max-width: 900px" class="wp-caption aligncenter"><div class="media-credit-container aligncenter" style="width: 900px"><img class="size-full wp-image-91013" src="https://www.kawowo.com/wp-content/uploads/2018/03/jb-sc-villa-line-up-vs-ura.jpg" alt="" width="900" height="600" srcset="https://www.kawowo.com/wp-content/uploads/2018/03/jb-sc-villa-line-up-vs-ura.jpg 900w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-sc-villa-line-up-vs-ura-480x320.jpg 480w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-sc-villa-line-up-vs-ura-768x512.jpg 768w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-sc-villa-line-up-vs-ura-300x200.jpg 300w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-sc-villa-line-up-vs-ura-128x85.jpg 128w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-sc-villa-line-up-vs-ura-32x21.jpg 32w" sizes="(max-width: 900px) 100vw, 900px" /><span class="media-credit">© Kawowo Sports | JOHN BATANUDDE</span></div><figcaption class="wp-caption-text">SC Villa line-up against URA at Masaka Recreational Stadium. The Jogoos won 2-0</figcaption></figure>
<p>During the reverse fixture played at the lake side Fisheries Training Institute play ground in Bugonga on 28<sup>th</sup> November 2017,<a href="https://www.kawowo.com/2017/11/28/sc-villa-outsmarts-masavu-extend-lead-top/" target="_blank" rel="noopener"> the Jogoos were mercy-less, winning 3-0 on the red letter day</a>.</p>
<p>Back then, Masavu first outstretched the Jogoos with a barren opening 45 minutes.</p><div class="g g-1"><div class="g-single a-6"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kaw_articles_large -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="6796140006"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<p>However, the visiting team worked tooth and nail for the much needed break through.</p>
<p>Team captain Bernard Muwanga opened the score sheet with a rare goal, a headed effort off Martin Kizza’s corner from the right wing.</p><!-- Either there are no banners, they are disabled or none qualified for this location! -->
<p>Midfielder Abel Eturude scored a beauty after dribbling past a forest and bodies before Yubu Bogere wrapped the scoring business on the day.</p>
<p>Between then and now, a lot of water has gone done the drain.</p>
<p>Masavu recruited ‘massively’ during the January transfer window break and SC Villa Jogoo added three names to their ranks.</p>
<p>Coming to the Wednesday game, SC Villa Jogoo currently leads the 16 team log with 40 points off 20 matches.</p>
<p>Ironically, Masavu lies rock bottom with 19 points and deficit of goals (16).</p>
<figure id="attachment_91005" style="max-width: 900px" class="wp-caption aligncenter"><div class="media-credit-container aligncenter" style="width: 900px"><img class="size-full wp-image-91005" src="https://www.kawowo.com/wp-content/uploads/2018/03/jb-martin-kizza-saidi-kyeyune-sc-villa-vs-ura.jpg" alt="" width="900" height="600" srcset="https://www.kawowo.com/wp-content/uploads/2018/03/jb-martin-kizza-saidi-kyeyune-sc-villa-vs-ura.jpg 900w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-martin-kizza-saidi-kyeyune-sc-villa-vs-ura-480x320.jpg 480w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-martin-kizza-saidi-kyeyune-sc-villa-vs-ura-768x512.jpg 768w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-martin-kizza-saidi-kyeyune-sc-villa-vs-ura-300x200.jpg 300w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-martin-kizza-saidi-kyeyune-sc-villa-vs-ura-128x85.jpg 128w, https://www.kawowo.com/wp-content/uploads/2018/03/jb-martin-kizza-saidi-kyeyune-sc-villa-vs-ura-32x21.jpg 32w" sizes="(max-width: 900px) 100vw, 900px" /><span class="media-credit">© Kawowo Sports | JOHN BATANUDDE</span></div><figcaption class="wp-caption-text">On form Martin Kizza in action against URA at Masaka</figcaption></figure>
<p><strong>Team news:</strong></p>
<p>After their successful trip away to Arua when the 16 time league winners piped Onduparaka 1-0, the Jogoos returned to Kampala on Sunday and only resumed training on Monday.</p>
<p>Muwanga who missed the Arua match due to accumulated cautions is expected back to play alongside either Henry Katongole or Isa Lumu in central defence.</p>
<p>Apart from left winger Vitalis Tabu, the rest of the Jogoo players are well in shape to face Masavu.</p>
<p>For the visiting Masavu, first choice goalie Salim Munaku is out with an injury, utility player Ddumba Sadala and so is defender Michael ‘Libero’ Otimong.</p>
<p>Sadala limped out of Masavu’s 1 all home draw last Friday against Bright Stars at Bugonga.</p>
<p>Munaku and Otimong were some of the 12 new faces recruited in the secondary transfer window.</p>
<p>Right back Moses Kiggundu continues to serve his suspension after being red carded against Maroons.</p>
<figure id="attachment_91441" style="max-width: 900px" class="wp-caption aligncenter"><div class="media-credit-container aligncenter" style="width: 900px"><img class="size-full wp-image-91441" src="https://www.kawowo.com/wp-content/uploads/2018/03/an-ibrahim-mpengele-nelson-senkatuka-msavu-vs-bright-stars.jpg" alt="" width="900" height="600" srcset="https://www.kawowo.com/wp-content/uploads/2018/03/an-ibrahim-mpengele-nelson-senkatuka-msavu-vs-bright-stars.jpg 900w, https://www.kawowo.com/wp-content/uploads/2018/03/an-ibrahim-mpengele-nelson-senkatuka-msavu-vs-bright-stars-480x320.jpg 480w, https://www.kawowo.com/wp-content/uploads/2018/03/an-ibrahim-mpengele-nelson-senkatuka-msavu-vs-bright-stars-768x512.jpg 768w, https://www.kawowo.com/wp-content/uploads/2018/03/an-ibrahim-mpengele-nelson-senkatuka-msavu-vs-bright-stars-300x200.jpg 300w, https://www.kawowo.com/wp-content/uploads/2018/03/an-ibrahim-mpengele-nelson-senkatuka-msavu-vs-bright-stars-128x85.jpg 128w, https://www.kawowo.com/wp-content/uploads/2018/03/an-ibrahim-mpengele-nelson-senkatuka-msavu-vs-bright-stars-32x21.jpg 32w" sizes="(max-width: 900px) 100vw, 900px" /><span class="media-credit">© Kawowo Sports | AISHA NAKATO</span></div><figcaption class="wp-caption-text">Masavu central defender Ibrahim Pengere heads away the ball as Bright Stars captain Nelson Senkatuka closes on</figcaption></figure>
<p><strong>Expected Key battles:</strong></p>
<p>Sports Club Villa Jogoo goalkeeper Samson Kirya and his defenders are expected to face a face a stern test from on form forward Abraham Ndugwa.</p>
<p>Ndugwa’s back ups Ivan Lubaale and Arthur Ssemazi will be expected to work an extra effort in order to penetrate the meanest defence (SC Villa Jogoo has conceded 8 goals) in the entire league.</p>
<p>Meanwhile, the Masavu defence line marshaled by Ibrahim Mpengere and Benjamin Nyakoojo will be tasked to keep out any danger posed by Yubu Bogere, Davis Kasirye, Alex Kitata and George Ssenkaaba.</p>
<p>Jogoo midfielders Nicholas Kasozi, Godfrey Lwesibawa, Martin Kizza and Abel Eturude will come face to face with Veron Ddamba, Simon Namwanja and company.</p>
<p>A win for either side will be crucial to their respective aspirations in the league.</p>
<figure id="attachment_84565" style="max-width: 900px" class="wp-caption aligncenter"><div class="media-credit-container aligncenter" style="width: 900px"><img class="size-full wp-image-84565" src="https://www.kawowo.com/wp-content/uploads/2017/11/Abel-Eturude-passes-the-ball.jpg" alt="" width="900" height="600" srcset="https://www.kawowo.com/wp-content/uploads/2017/11/Abel-Eturude-passes-the-ball.jpg 900w, https://www.kawowo.com/wp-content/uploads/2017/11/Abel-Eturude-passes-the-ball-480x320.jpg 480w, https://www.kawowo.com/wp-content/uploads/2017/11/Abel-Eturude-passes-the-ball-768x512.jpg 768w, https://www.kawowo.com/wp-content/uploads/2017/11/Abel-Eturude-passes-the-ball-300x200.jpg 300w, https://www.kawowo.com/wp-content/uploads/2017/11/Abel-Eturude-passes-the-ball-128x85.jpg 128w, https://www.kawowo.com/wp-content/uploads/2017/11/Abel-Eturude-passes-the-ball-32x21.jpg 32w" sizes="(max-width: 900px) 100vw, 900px" /><span class="media-credit">© Kawowo Sports | DAVID ISABIRYE</span></div><figcaption class="wp-caption-text">Abel Eturude passes the ball as Abraham Ndugwa closes by. He scored a beauty against Masavu at Bugonga stadium during the first round</figcaption></figure>
<p><strong>Coaches speak out:</strong></p>
<p><strong>Alex Gitta &#8211; Assistant coach, Masavu</strong></p>
<blockquote><p>We respect SC Villa Jogoo. But, we know it very well, we can work for any result home or away</p></blockquote>
<p><strong>Wasswa Bbosa &#8211; SC Villa, Head coach</strong></p>
<blockquote><p>Masavu changed from the one we knew in the first round. We shall fight from start to finish.</p></blockquote>
</p>			</div><!-- .entry-content -->

	<footer class="entry-footer col-xs-12">
		<div class="kawowo-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-91773" class="share-facebook sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-91773" class="share-twitter sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=Top%20versus%20bottom%20contest%20as%20Sports%20Club%20Villa%20Jogoo%20entertains%20Masavu%20in%20Masaka https%3A%2F%2Fgoo.gl%2FecTpu4" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-91773" class="share-google-plus-1 sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-91773" class="share-linkedin sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.kawowo.com/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div>	</footer><!-- .entry-footer -->

	</div><!-- .row -->

</article><!-- #post-## -->

						<div class="kawowo-related-posts col-md-12">
				<h3><span>You May Also Like</span></h3>
				<div class="row">
			 						<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://www.kawowo.com/2018/03/13/birungi-stars-as-express-humiliates-soana-at-wankulukuku-uganda-premier-league/" title="Birungi stars as Express humiliates Soana at Wankulukuku | Uganda Premier League" style="background: url( https://www.kawowo.com/wp-content/uploads/2018/03/jb-michale-birungi-celebrates-against-soana-480x320.jpg ) center no-repeat;background-size: cover;"></a>
										 		<p><a href="https://www.kawowo.com/2018/03/13/birungi-stars-as-express-humiliates-soana-at-wankulukuku-uganda-premier-league/" title="Birungi stars as Express humiliates Soana at Wankulukuku | Uganda Premier League">Birungi stars as Express humiliates Soana at Wankulukuku | Uganda Premier League</a></p>
					</div>
									<div class="col-xs-12 col-md-4">
										 		<p><a href="https://www.kawowo.com/2018/03/13/live-express-vs-soana-uganda-premier-league/" title="LIVE: Express vs. Soana | Uganda Premier League">LIVE: Express vs. Soana | Uganda Premier League</a></p>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://www.kawowo.com/2018/03/13/lady-doves-outwit-panyadoli-to-qualify-for-round-of-16-fufa-women-cup/" title="Lady Doves outwit Panyadoli to qualify for round of 16 | FUFA Women Cup" style="background: url( https://www.kawowo.com/wp-content/uploads/2018/03/Masindi-Doves-480x360.jpg ) center no-repeat;background-size: cover;"></a>
										 		<p><a href="https://www.kawowo.com/2018/03/13/lady-doves-outwit-panyadoli-to-qualify-for-round-of-16-fufa-women-cup/" title="Lady Doves outwit Panyadoli to qualify for round of 16 | FUFA Women Cup">Lady Doves outwit Panyadoli to qualify for round of 16 | FUFA Women Cup</a></p>
					</div>
								</div>
			</div>
		
			
			
<div id="comments" class="comments-area col-md-12">

	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/03/14/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&#038;postid=91773&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.9&#038;sig=8c70de65bed5404caa73b673509845573a3673fc#parent=https%3A%2F%2Fwww.kawowo.com%2F2018%2F03%2F14%2Ftop-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

<div id="secondary" class="widget-area col-lg-4" role="complementary">
	<div class="theiaStickySidebar">
	<aside id="ajdg_bnnrwidgets-11" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Kawowo_sidebar_center -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="1792287653"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="facebook-likebox-2" class="widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/kawowosports" data-width="300"  data-height="300" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/kawowosports"><a href="https://www.facebook.com/kawowosports"></a></blockquote></div>
		</div>
		</aside>
<!-- WordPress Popular Posts Plugin [W] [daily] [views] [custom] -->

<aside id="wpp-2" class="widget popular-posts">
<h2 class="widget-title"><span>Popular</span></h2><!-- cached --><ul class="fat-wpp-list"><li><div class="fat-wpp-image"><a href="https://www.kawowo.com/2018/03/13/onduparaka-fans-want-mbabazi-baganda-players-out/" title="Onduparaka fans want Mbabazi, &#039;Baganda Players&#039; out"><img width="480" height="320" src="https://www.kawowo.com/wp-content/uploads/2017/05/jb_livingstone_mbabazi_onduparaka_09052017-480x320.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://www.kawowo.com/wp-content/uploads/2017/05/jb_livingstone_mbabazi_onduparaka_09052017-480x320.jpg 480w, https://www.kawowo.com/wp-content/uploads/2017/05/jb_livingstone_mbabazi_onduparaka_09052017-768x512.jpg 768w, https://www.kawowo.com/wp-content/uploads/2017/05/jb_livingstone_mbabazi_onduparaka_09052017-300x200.jpg 300w, https://www.kawowo.com/wp-content/uploads/2017/05/jb_livingstone_mbabazi_onduparaka_09052017-128x85.jpg 128w, https://www.kawowo.com/wp-content/uploads/2017/05/jb_livingstone_mbabazi_onduparaka_09052017-32x21.jpg 32w, https://www.kawowo.com/wp-content/uploads/2017/05/jb_livingstone_mbabazi_onduparaka_09052017.jpg 900w" sizes="(max-width: 480px) 100vw, 480px" /></a><div class="fat-wpp-image-cat"><a href="https://www.kawowo.com/football/">Football</a></div></div><h2 class="entry-title"><a href="https://www.kawowo.com/2018/03/13/onduparaka-fans-want-mbabazi-baganda-players-out/" title="Onduparaka fans want Mbabazi, &#039;Baganda Players&#039; out">Onduparaka fans want Mbabazi, 'Baganda Players' out</a></h2></li></ul>
</aside>
<aside id="ajdg_bnnrwidgets-2" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Kawowo_sidebar_center -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="1792287653"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="twitter_timeline-3" class="widget widget_twitter_timeline"><a class="twitter-timeline" data-width="320" data-height="300" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" href="https://twitter.com/KawowoSports">My Tweets</a></aside><aside id="ajdg_bnnrwidgets-8" class="widget ajdg_bnnrwidgets"><div class="a-single a-7"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Kawowo-Right-sidebar_bottom -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="3057147601"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="ajdg_bnnrwidgets-4" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Kawowo_sidebar_center -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="1792287653"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="social_media_icons_widget_by_fat-4" class="widget widget_social_media_icons_widget_by_fat"><ul><li><a title="View kawowosports&#8217;s profile on Facebook" href="https://www.facebook.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Facebook</span><span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Twitter" href="https://twitter.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Twitter</span><span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Instagram" href="https://instagram.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Instagram</span><span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></span></a></li><li><a title="View kawowo&#8217;s profile on Google+" href="https://plus.google.com/u/0/+kawowo/" target="_blank"><span class="screen-reader-text">View kawowo&#8217;s profile on Google+</span><span><svg viewBox="0 0 36 28"><path d="M22.453 14.266q0 3.25-1.359 5.789t-3.875 3.969-5.766 1.43q-2.328 0-4.453-0.906t-3.656-2.438-2.438-3.656-0.906-4.453 0.906-4.453 2.438-3.656 3.656-2.438 4.453-0.906q4.469 0 7.672 3l-3.109 2.984q-1.828-1.766-4.562-1.766-1.922 0-3.555 0.969t-2.586 2.633-0.953 3.633 0.953 3.633 2.586 2.633 3.555 0.969q1.297 0 2.383-0.359t1.789-0.898 1.227-1.227 0.766-1.297 0.336-1.156h-6.5v-3.938h10.813q0.187 0.984 0.187 1.906zM36 12.359v3.281h-3.266v3.266h-3.281v-3.266h-3.266v-3.281h3.266v-3.266h3.281v3.266h3.266z"></path></svg></span></a></li></ul></aside>	</div>
</div><!-- #secondary -->
</div><!-- .row -->

	</div><!-- #content -->

			<div id="left-sidebar" class="left-sidebar-area">
				<div class="left-sidebar-content">
					<div class="left-header">
					<div class="left-logo">
						<a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png" class="custom-logo" alt="Kawowo Sports" itemprop="logo" srcset="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png 888w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-480x135.png 480w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-768x216.png 768w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-722x203.png 722w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-300x84.png 300w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-128x36.png 128w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-32x9.png 32w" sizes="(max-width: 888px) 100vw, 888px" /></a>					<button class="left-sidebar-close" title="Close"><svg><line stroke-miterlimit="10" x1="0.354" y1="0.354" x2="14.354" y2="14.354"/><line stroke-miterlimit="10" x1="14.354" y1="0.354" x2="0.354" y2="14.354"/></svg></button>
					</div>
					</div>
					<nav id="site-navigation" class="main-navigation" role="navigation">
								<div class="menu-mainmenu-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42339"><a href="https://www.kawowo.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42340"><a href="https://www.kawowo.com/football/">Football</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42346"><a href="https://www.kawowo.com/basketball/">Basketball</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42347"><a href="https://www.kawowo.com/rugby/">Rugby</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42350"><a href="https://www.kawowo.com/motorsport/">Motorsport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.kawowo.com/cricket/">Cricket</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42348"><a href="https://www.kawowo.com/athletics/">Athletics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42349"><a href="https://www.kawowo.com/golf/">Golf</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42345"><a>More</a><span class="expand-submenu" title="Expand">&#43;</span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42351"><a href="https://www.kawowo.com/pool/">Pool</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42343"><a href="https://www.kawowo.com/weightlifting/">Weightlifting</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42344"><a href="https://www.kawowo.com/volleyball/">Volleyball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82243"><a href="https://www.kawowo.com/chess/">Chess</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82244"><a href="https://www.kawowo.com/others/">Others</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82245"><a href="https://www.kawowo.com/boxing/">Boxing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82246"><a href="https://www.kawowo.com/cycling/">Cycling</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82247"><a href="https://www.kawowo.com/hockey/">Hockey</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82248"><a href="https://www.kawowo.com/lacrosse/">Lacrosse</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82249"><a href="https://www.kawowo.com/live/">Live</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82251"><a href="https://www.kawowo.com/rowing/">Rowing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82250"><a href="https://www.kawowo.com/netball/">Netball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82252"><a href="https://www.kawowo.com/swimming/">Swimming</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82253"><a href="https://www.kawowo.com/tennis/">Tennis</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42352"><a href="https://www.kawowo.com/opinion/">Op-eds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55773"><a>STATS</a><span class="expand-submenu" title="Expand">&#43;</span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55774"><a href="https://www.kawowo.com/table/2017-18-upl-table/">UPL Table Standings</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55783"><a href="https://www.kawowo.com/calendar/results/">All Results</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55780"><a href="https://www.kawowo.com/calendar/fixtures/">All Fixtures</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78030"><a href="https://www.kawowo.com/list/201718-uganda-premier-league-top-scorers/">UPL top scorers</a></li>
</ul>
</li>
</ul></div>					</nav><!-- #site-navigation -->
					
<div id="tetriary" class="left-widget-area" role="complementary">
	<aside id="ajdg_bnnrwidgets-6" class="widget ajdg_bnnrwidgets"><!-- Error, Ad is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside></div><!-- #tetriary -->
					<div class="site-info">
			<p>© 2018 Kawowo Sports. All Rights reserved.</p>
<p>Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>					</div><!-- .site-info -->
				</div>
			</div>
		<div class="left-sidebar-bg">
		</div><!-- .left-sidebar-bg -->
			<div id="bottom-widget" class="widget-area container" role="complementary">
		<div class="row">
	    <aside id="ajdg_bnnrwidgets-10" class="widget col-xs-12 ajdg_bnnrwidgets"><div class="a-single a-5"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kaw-leaderboard -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="9585332407"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>		</div>
	</div><!-- #bottom-widget -->
		<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
		<a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png" class="custom-logo" alt="Kawowo Sports" itemprop="logo" srcset="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png 888w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-480x135.png 480w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-768x216.png 768w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-722x203.png 722w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-300x84.png 300w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-128x36.png 128w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-32x9.png 32w" sizes="(max-width: 888px) 100vw, 888px" /></a>				<a class="kawowo-extra-footer-image" href="http://owinosolutions.com/"><img src="https://www.kawowo.com/wp-content/uploads/2016/11/owino1-e1478170366337.jpg" alt=""></a>
			<p>© 2018 Kawowo Sports. All Rights reserved.</p>
<p>Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

	<div style="display:none">
	<div class="grofile-hash-map-bf4f394b0ee6e64b56f7989d565a6c04">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.kawowo.com\/2018\/03\/14\/top-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka\/":91773};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.kawowo.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201811'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/js/jquery.dataTables.min.js?ver=1.10.4'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/js/jquery.countdown.min.js?ver=2.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var localized_strings = {"days":"days","hrs":"hrs","mins":"mins","secs":"secs","previous":"Previous","next":"Next"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/js/sportspress.js?ver=2.5.10'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-match-stats/js/jquery.waypoints.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-match-stats/js/sportspress-match-stats.js?ver=2.2'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-scoreboard/js/sportspress-scoreboard.js?ver=1521001160'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-sponsors/js/sportspress-sponsors.js?ver=1521001160'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/js/sportspress-tournaments.js?ver=2.3'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/slick/slick.min.js?ver=20150828'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/js/theia-sticky-sidebar.min.js?ver=1.2.2'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/js/jquery.magnific-popup.min.js?ver=20150829'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/ui/effect-slide.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var kawowo = {"home_page_slider_img_number":"1","loadMoreText":"Load more posts","loadingText":" ","noMorePostsText":"No More Posts","expandText":"Expand","closeText":"Close","startPage":"1","maxPages":"0","nextLink":null,"pagination":"infinite","getTemplateDirectoryUri":"https:\/\/www.kawowo.com\/wp-content\/themes\/kawowo-sports","months":["January","February","March","April","May","June","July","August","September","October","November","December"],"days":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/js/kawowo.min.js?ver=20160908'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/js/skip-link-focus-fix.min.js?ver=20130115'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=5.9'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=5.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
			<script type="text/javascript">
			jQuery(document).ready( function($) {
				$('.sp-header-loaded').prepend( $('.sp-league-menu') );
			} );
			</script>
					<script type="text/javascript">
			jQuery(document).ready( function($) {
				$('.sp-header-loaded').prepend( $('.sp-header-scoreboard') );
			} );
			</script>
		<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
}});
</script>
<!-- /AdRotate JS -->


		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&postid=91773&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.9&sig=8c70de65bed5404caa73b673509845573a3673fc#parent=https%3A%2F%2Fwww.kawowo.com%2F2018%2F03%2F14%2Ftop-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&postid=91773&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.9&sig=8c70de65bed5404caa73b673509845573a3673fc#parent=https%3A%2F%2Fwww.kawowo.com%2F2018%2F03%2F14%2Ftop-versus-bottom-contest-as-sports-club-villa-jogoo-entertains-masavu-in-masaka%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201811.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'119498450',post:'91773',tz:'3',srv:'www.kawowo.com'} ]);
	_stq.push([ 'clickTrackerInit', '119498450', '91773' ]);
</script>

</body>
</html>
