<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.kawowo.com/xmlrpc.php">

<title>﻿Bashir Mutanda wants to keep improving &#8211; Kawowo Sports</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Feed" href="https://www.kawowo.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Comments Feed" href="https://www.kawowo.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; ﻿Bashir Mutanda wants to keep improving Comments Feed" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.3.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.3.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-20862137-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-20862137-4', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.kawowo.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.kawowo.com/wp-content/plugins/gutenberg/build/block-library/style.css?ver=1542806632' type='text/css' media='all' />
<link rel='stylesheet' id='media-credit-css'  href='https://www.kawowo.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=3.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.kawowo.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-general-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/css/sportspress.css?ver=2.6.14' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-icons-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/css/icons.css?ver=2.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-league-menu-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-league-menu/css/sportspress-league-menu.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-event-statistics-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-match-stats/css/sportspress-match-stats.css?ver=2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-results-matrix-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-results-matrix/css/sportspress-results-matrix.css?ver=2.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-scoreboard-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-scoreboard/css/sportspress-scoreboard.css?ver=2.6.11' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-scoreboard-ltr-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-scoreboard/css/sportspress-scoreboard-ltr.css?ver=2.6.11' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-sponsors-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-sponsors/css/sportspress-sponsors.css?ver=2.6.14' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-timelines-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-timelines/css/sportspress-timelines.css?ver=2.6' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-tournaments-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/css/sportspress-tournaments.css?ver=2.6.14' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-tournaments-ltr-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/css/sportspress-tournaments-ltr.css?ver=2.6.14' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-bracket-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/css/jquery.bracket.min.css?ver=0.11.0' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-twitter-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-twitter/css/sportspress-twitter.css?ver=2.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='sportspress-user-scores-css'  href='//www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-user-scores/css/sportspress-user-scores.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.kawowo.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='kawowo-style-css'  href='https://www.kawowo.com/wp-content/themes/kawowo-sports/style.css?ver=4.9.8' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link crossorigin="anonymous" rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.kawowo.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<style type="text/css"> /* SportsPress Custom CSS */ .sp-league-table tr:nth-last-child(-n+3) td {
	background: #f08080 !important;
}
.sp-league-table tr:nth-child(-n+1) td {
background: lightgreen !important;
}</style><script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.kawowo.com","track_download_as":"pageview","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.3.2'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-facebook/js/sportspress-facebook-sdk.js?ver=2.11'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/js/jquery.bracket.min.js?ver=0.11.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"10","ajax_url":"https:\/\/www.kawowo.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"112206","token":"6d48585a86","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.8.1'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.8.1'></script>
<link rel='https://api.w.org/' href='https://www.kawowo.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.kawowo.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.kawowo.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='KCCA Player Ratings: KCCA 3-0 Mtibwa Sugars | CAF CC' href='https://www.kawowo.com/2018/12/16/kcca-player-ratings-kcca-3-0-mtibwa-sugars-caf-cc/' />
<link rel='next' title='Thousands embrace the Kampala Kids Run 2018' href='https://www.kawowo.com/2018/12/16/thousands-embrace-the-kampala-kids-run-2018/' />
<meta name="generator" content="WordPress 4.9.8" />
<meta name="generator" content="SportsPress 2.6.14" />
<meta name="generator" content="SportsPress Pro 2.6.14" />
<link rel="canonical" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/" />
<link rel='shortlink' href='https://goo.gl/XQXEb6' />
<link rel="alternate" type="application/json+oembed" href="https://www.kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kawowo.com%2F2018%2F12%2F16%2F%25ef%25bb%25bfbashir-mutanda-wants-to-keep-improving%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kawowo.com%2F2018%2F12%2F16%2F%25ef%25bb%25bfbashir-mutanda-wants-to-keep-improving%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.16 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 {  margin: 0 auto; }
	.g-4 {  margin: 0 auto; }
	.g-5 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
		<script type="text/javascript">
			var _sf_async_config = _sf_async_config || {};
			_sf_async_config.uid = 65763;
			_sf_async_config.domain = "kawowo.com";
			_sf_async_config.useCanonical = true;
		</script>
		<script src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
				<meta property="fb:pages" content="145227195529292" />
							<meta property="ia:markup_url" content="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?ia_markup=1" />
				
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
		<style type="text/css">
		#secondary .widget:nth-of-type(3n+1), #secondary .widget:nth-of-type(3n+1) .widget-title span {background-color:#ffffff;}
		#secondary .widget:nth-of-type(3n+2), #secondary .widget:nth-of-type(3n+2) .widget-title span {background-color:#ffffff;}
		#secondary .widget:nth-of-type(3n+3), #secondary .widget:nth-of-type(3n+3) .widget-title span {background-color:#ffffff;}
		.home, .archive, .search, .home .slick-prev:after, .home .slick-next:after, .home #secondary .widget_social_media_icons_widget_by_fat li, .archive #secondary .widget_social_media_icons_widget_by_fat li, .search #secondary .widget_social_media_icons_widget_by_fat li, .home #secondary .widget.widget_mc4wp_form_widget, .home #secondary .widget.widget_mc4wp_form_widget .widget-title span, .home #bottom-widget .widget-title span, .home #top-widget .widget-title span, .archive #secondary .widget.widget_mc4wp_form_widget, .archive #secondary .widget.widget_mc4wp_form_widget .widget-title span, .archive #bottom-widget .widget-title span, .archive #top-widget .widget-title span, .search #secondary .widget.widget_mc4wp_form_widget, .search #secondary .widget.widget_mc4wp_form_widget .widget-title span, .search #bottom-widget .widget-title span, .search #top-widget .widget-title span {background-color: #f5f5f5;}
						svg:hover,a svg:hover,.kawowo-author-social-icons a:hover svg {fill: #ff0000;}
		button,input[type="button"],input[type="reset"],input[type="submit"],.navbar-navigation .current_page_item > a:after,.navbar-navigation .current-menu-item > a:after,.navbar-navigation .current_page_ancestor > a:after,.navbar-navigation .current-menu-ancestor > a:after {border: 1px solid #ff0000;}
		button:hover,input[type="button"]:hover,input[type="reset"]:hover,input[type="submit"]:hover,a:hover,a:focus,a:active,.navbar-navigation ul ul .current_page_item > a,.navbar-navigation ul ul .current-menu-item > a,.navbar-navigation ul ul .current_page_ancestor > a,.navbar-navigation ul ul .current-menu-ancestor > a,.navbar-navigation a:hover,.main-navigation ul .current_page_item > a,
		.main-navigation ul .current-menu-item > a,.main-navigation ul .current_page_ancestor > a,.main-navigation ul .current-menu-ancestor > a,.main-navigation ul .current_page_item > .expand-submenu,.main-navigation ul .current-menu-item > .expand-submenu,.main-navigation ul .current_page_ancestor > .expand-submenu,.main-navigation ul .current-menu-ancestor > .expand-submenu,.widget_nav_menu ul .current_page_item > a,.widget_nav_menu ul .current-menu-item > a,.widget_nav_menu ul .current_page_ancestor > a,.widget_nav_menu ul .current-menu-ancestor > a,.widget_nav_menu ul .current_page_item > .expand-submenu,.widget_nav_menu ul .current-menu-item > .expand-submenu,.widget_nav_menu ul .current_page_ancestor > .expand-submenu,.widget_nav_menu ul .current-menu-ancestor > .expand-submenu,.nav-links a:hover > .kawowo-next-article-title,.nav-links a:hover > .kawowo-previous-article-title,.nav-links a:hover > .kawowo-next-article,.nav-links a:hover > .kawowo-previous-article,.main-navigation .expand-submenu:hover,.widget_nav_menu .expand-submenu:hover,.main-navigation a:hover,.widget_nav_menu a:hover,.nav-social a:hover svg,.left-nav-social a:hover svg {color: #ff0000;}
		.kawowo-search-panel .kawowo-search-panel-close:hover,
		.menu-toggle:hover,
		.search-toggle:hover,
		button,
		input[type="button"],
		input[type="reset"],
		input[type="submit"] {background-color: #ff0000;}
		.left-sidebar-close:hover svg line {stroke: #ff0000;}
		@media screen and (min-width: 992px )  {
		.menu-logo {float:left;}
		.navbar-navigation ul, .nav-social {display:block;}
		/*.kawowo-featured-slider, .kawowo-featured-slider .featured-image, .kawowo-featured-slider .no-featured-image {height:500px;}*/
		}
		</style>
		<link rel="amphtml" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="﻿Bashir Mutanda wants to keep improving" />
<meta property="og:url" content="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/" />
<meta property="og:description" content="Bashir Mutanda is joined by Charles Lwanga in celebrating his first goal [Photo: JOHN BATANUDDE] Bashir Mutanda says he wants to continue improving his game in order to help his team as well. The S…" />
<meta property="article:published_time" content="2018-12-16T10:59:02+00:00" />
<meta property="article:modified_time" content="2018-12-16T10:59:07+00:00" />
<meta property="og:site_name" content="Kawowo Sports" />
<meta property="og:image" content="https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-celebrations.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="637" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@KawowoSports" />
<meta name="twitter:text:title" content="﻿Bashir Mutanda wants to keep improving" />
<meta name="twitter:image" content="https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-celebrations.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://www.kawowo.com/wp-content/uploads/2016/11/favicon-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg" />
<meta name="msapplication-TileImage" content="https://www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg" />
</head>

<body class="post-template-default single single-post postid-112206 single-format-standard wp-custom-logo group-blog">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">

				<nav id="top-navigation" class="navbar-navigation" role="navigation">

					<button id="left-navbar-toggle" class="menu-toggle" aria-controls="left-sidebar" aria-expanded="false"><span class="screen-reader-text">Menu</span><svg><path d="M3 6h18v2.016h-18v-2.016zM3 12.984v-1.969h18v1.969h-18zM3 18v-2.016h18v2.016h-18z"></path></svg></button>
					<button id="navbar-search-toggle" class="search-toggle" aria-controls="search-panel" aria-expanded="false"><span class="screen-reader-text">Search</span><svg><path d="M9.516 14.016q1.875 0 3.188-1.313t1.313-3.188-1.313-3.188-3.188-1.313-3.188 1.313-1.313 3.188 1.313 3.188 3.188 1.313zM15.516 14.016l4.969 4.969-1.5 1.5-4.969-4.969v-0.797l-0.281-0.281q-1.781 1.547-4.219 1.547-2.719 0-4.617-1.875t-1.898-4.594 1.898-4.617 4.617-1.898 4.594 1.898 1.875 4.617q0 2.438-1.547 4.219l0.281 0.281h0.797z"></path></svg></button>
					<div id="search-panel" class="kawowo-search-panel">
					    <button class="kawowo-search-panel-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button>
						<form role="search" method="get" class="search-form" action="https://www.kawowo.com/">
	<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field" placeholder="Type and hit enter" value="" name="s" title="Search for:" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
						<div id="menu-social-widget" class="widget-area menu-social-widget" role="complementary">
		<aside id="social_media_icons_widget_by_fat-3" class="widget widget_social_media_icons_widget_by_fat"><ul><li><a title="View kawowosports&#8217;s profile on Facebook" href="https://www.facebook.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Facebook</span><span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Twitter" href="https://twitter.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Twitter</span><span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></span></a></li><li><a title="View KawowoSports&#8217;s profile on Instagram" href="https://instagram.com/KawowoSports/" target="_blank"><span class="screen-reader-text">View KawowoSports&#8217;s profile on Instagram</span><span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></span></a></li><li><a title="View Kawowo&#8217;s profile on Google+" href="https://plus.google.com/u/0/+Kawowo/" target="_blank"><span class="screen-reader-text">View Kawowo&#8217;s profile on Google+</span><span><svg viewBox="0 0 36 28"><path d="M22.453 14.266q0 3.25-1.359 5.789t-3.875 3.969-5.766 1.43q-2.328 0-4.453-0.906t-3.656-2.438-2.438-3.656-0.906-4.453 0.906-4.453 2.438-3.656 3.656-2.438 4.453-0.906q4.469 0 7.672 3l-3.109 2.984q-1.828-1.766-4.562-1.766-1.922 0-3.555 0.969t-2.586 2.633-0.953 3.633 0.953 3.633 2.586 2.633 3.555 0.969q1.297 0 2.383-0.359t1.789-0.898 1.227-1.227 0.766-1.297 0.336-1.156h-6.5v-3.938h10.813q0.187 0.984 0.187 1.906zM36 12.359v3.281h-3.266v3.266h-3.281v-3.266h-3.266v-3.281h3.266v-3.266h3.281v3.266h3.266z"></path></svg></span></a></li></ul></aside>	</div><!-- #menu-social-widget -->
					<div class="menu-logo">
						<a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png" class="custom-logo" alt="Kawowo Sports" itemprop="logo" srcset="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png 888w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-480x135.png 480w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-768x216.png 768w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-722x203.png 722w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-300x84.png 300w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-128x36.png 128w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-32x9.png 32w" sizes="(max-width: 888px) 100vw, 888px" /></a>					</div>
						<div class="menu-mainmenu-container"><ul id="top-menu" class="menu"><li id="menu-item-42339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42339"><a href="https://www.kawowo.com">Home</a></li>
<li id="menu-item-42340" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42340"><a href="https://www.kawowo.com/category/football/">Football</a></li>
<li id="menu-item-42346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42346"><a href="https://www.kawowo.com/category/basketball/">Basketball</a></li>
<li id="menu-item-42347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42347"><a href="https://www.kawowo.com/category/rugby/">Rugby</a></li>
<li id="menu-item-42350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42350"><a href="https://www.kawowo.com/category/motorsport/">Motorsport</a></li>
<li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.kawowo.com/category/cricket/">Cricket</a></li>
<li id="menu-item-42348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42348"><a href="https://www.kawowo.com/category/athletics/">Athletics</a></li>
<li id="menu-item-42349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42349"><a href="https://www.kawowo.com/category/golf/">Golf</a></li>
<li id="menu-item-42345" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42345"><a>More</a><span class="expand-submenu" title="Expand">&#43;</span>
<ul class="sub-menu">
	<li id="menu-item-42351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42351"><a href="https://www.kawowo.com/category/pool/">Pool</a></li>
	<li id="menu-item-42343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42343"><a href="https://www.kawowo.com/category/weightlifting/">Weightlifting</a></li>
	<li id="menu-item-42344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42344"><a href="https://www.kawowo.com/category/volleyball/">Volleyball</a></li>
	<li id="menu-item-82243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82243"><a href="https://www.kawowo.com/category/chess/">Chess</a></li>
	<li id="menu-item-82244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82244"><a href="https://www.kawowo.com/category/others/">Others</a></li>
	<li id="menu-item-82245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82245"><a href="https://www.kawowo.com/category/boxing/">Boxing</a></li>
	<li id="menu-item-82246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82246"><a href="https://www.kawowo.com/category/cycling/">Cycling</a></li>
	<li id="menu-item-82247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82247"><a href="https://www.kawowo.com/category/hockey/">Hockey</a></li>
	<li id="menu-item-82248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82248"><a href="https://www.kawowo.com/category/lacrosse/">Lacrosse</a></li>
	<li id="menu-item-82249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82249"><a href="https://www.kawowo.com/category/live/">Live</a></li>
	<li id="menu-item-82251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82251"><a href="https://www.kawowo.com/category/rowing/">Rowing</a></li>
	<li id="menu-item-82250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82250"><a href="https://www.kawowo.com/category/netball/">Netball</a></li>
	<li id="menu-item-82252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82252"><a href="https://www.kawowo.com/category/swimming/">Swimming</a></li>
	<li id="menu-item-82253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82253"><a href="https://www.kawowo.com/category/tennis/">Tennis</a></li>
	<li id="menu-item-110032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110032"><a href="https://www.kawowo.com/category/american-football/">American Football</a></li>
</ul>
</li>
<li id="menu-item-42352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42352"><a href="https://www.kawowo.com/category/opinion/">Op-eds</a></li>
<li id="menu-item-55773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55773"><a>STATS</a><span class="expand-submenu" title="Expand">&#43;</span>
<ul class="sub-menu">
	<li id="menu-item-55774" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55774"><a href="https://www.kawowo.com/table/2018-19-upl-table/">UPL Table Standings</a></li>
	<li id="menu-item-55783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55783"><a href="https://www.kawowo.com/calendar/results/">All Results</a></li>
	<li id="menu-item-55780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55780"><a href="https://www.kawowo.com/calendar/fixtures/">All Fixtures</a></li>
	<li id="menu-item-78030" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78030"><a href="https://www.kawowo.com/list/2018-19uganda-premier-league-top-scorers/">UPL top scorers</a></li>
</ul>
</li>
</ul></div>		</nav><!-- #site-navigation -->

	    
	</header><!-- #masthead -->

	<div id="content" class="site-content container">
		<div class="row">
	<div id="top-ads-widget" class="widget-area col-xs-12" role="complementary">
	    <aside id="ajdg_bnnrwidgets-7" class="widget ajdg_bnnrwidgets"><div class="a-single a-1"><!-- Revive Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.1.3 -->
<ins data-revive-zoneid="9" data-revive-id="beba77153dbe07400da103c85884534b"></ins>
<script async src="//batraim.com/ads/www/delivery/asyncjs.php"></script></div></aside>	</div><!-- #top-widget -->
</div>
<div class="row">
		<div id="primary" class="content-area col-lg-8">
		<main id="main" class="site-main row" role="main">

		
			
<article id="post-112206" class="col-md-12 post-112206 post type-post status-publish format-standard has-post-thumbnail hentry category-football">
	<header class="entry-header row">
		<div class="single-header col-xs-12">
		<div class="category-list">
		<a href="https://www.kawowo.com/category/football/">Football</a>		</div>
		<h1 class="entry-title">﻿Bashir Mutanda wants to keep improving</h1>	</div>
		<div class="col-xs-12 col-sm-8 col-sm-push-4 col-md-9 col-md-push-3 col-lg-9 col-lg-push-3 col-xl-10 col-xl-push-2">
			<div class="kawowo-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-112206" class="share-facebook sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-112206" class="share-twitter sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=%EF%BB%BFBashir%20Mutanda%20wants%20to%20keep%20improving%20https%3A%2F%2Fgoo.gl%2FXQXEb6" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow noopener noreferrer" data-shared="sharing-google-112206" class="share-google-plus-1 sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-112206" class="share-linkedin sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div>			<div class="entry-meta">
				<span class="posted-on"><a href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/" rel="bookmark"><time class="entry-date published updated" datetime="2018-12-16T13:59:02+00:00">5 hours</time></a> ago</span><br/><span class="byline">  by <span class="author vcard"><a class="url fn n" href="https://www.kawowo.com/author/isma/">Ismael Kiyonga</a></span></span>			</div><!-- .entry-meta -->
		</div>

		<div class='author-avatar-wrapper col-xs-12 col-sm-4 col-sm-pull-8 col-md-3 col-md-pull-9 col-xl-2 col-xl-pull-10'>
			<div class="author-avatar"><img alt='' src='https://secure.gravatar.com/avatar/27b5cc4e8b9a4bcc9b25568befc5d06f?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/27b5cc4e8b9a4bcc9b25568befc5d06f?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></div><div class="kawowo-author-social-icons"><a href="https://twitter.com/IsmaelKiyonga" title="Twitter" target="_blank"><span class="screen-reader-text">Twitter</span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></a><a href="https://www.facebook.com/kiyonga.ismael" title="Facebook" target="_blank"><span class="screen-reader-text">Facebook</span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></a></div>		</div>
	</header><!-- .entry-header -->
		<div class="row">

	<div class="entry-content col-xs-12 col-lg-10 col-lg-push-2">
		
<figure class="wp-block-image"><img src="https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-against-Expres.jpg" alt="" class="wp-image-112161" srcset="https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-against-Expres.jpg 900w, https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-against-Expres-480x320.jpg 480w, https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-against-Expres-768x512.jpg 768w, https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-against-Expres-300x200.jpg 300w, https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-against-Expres-128x85.jpg 128w, https://www.kawowo.com/wp-content/uploads/2018/12/Mutanda-Bashir-against-Expres-32x21.jpg 32w" sizes="(max-width: 900px) 100vw, 900px" /><figcaption>Bashir Mutanda is joined by Charles Lwanga in celebrating his first goal 
[Photo: JOHN BATANUDDE]</figcaption></figure>



<p><br><strong>Ba</strong>shir Mutanda says he wants to continue improving his game in order to help his team as well.</p>



<p>The SC Villa forward is enjoying the form of his life scoring in six successive league games including a brace that downed rivals Express FC at Namboole on Friday.</p>



<p><strong>“</strong>It’s a proud moment scoring two goals against our arch rivals,” said Mutanda. “But the most important thing is that the team has picked points since we were desperate for such a result,” he added.</p><div class="g g-1"><div class="g-single a-14"><a href="http://clickmeterlink.com/tbet" target="_blank"><img src="https://www.kawowo.com/wp-content/uploads/2018/07/topbet_26072018.gif" /></a></div></div>



<p>On his form that has seen him go top of the goalscorers’ charts, Mutanda says its team work and personally wants to keep banging in the goals.</p>



<p>“As a player, I want to keep improving every day. The form is down to hard work, team work as well as the technical team.</p>



<p>The former Vipers player spent two seasons on loan at Kirinya Jinja SS under coach Charles Ayiekoh and was lured to move to Villa Park by Moses Basena who quit after eight games without a win.<strong> </strong></p><div class="g g-4"><div class="g-single a-6"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="8608536158"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>



<blockquote class="wp-block-quote"><p><strong>“</strong>Coach Basena gave me chance to play here and am grateful whenever I don the Villa Jersey. Special thanks to him as well as coach Ayiekoh who has been so supportive in my career so far.</p></blockquote>



<p>Mutanda and SC Villa are now four points above the drop zone after an abysmal start to the campaign and next on menu is a trip to Paidha Black Angels on December 29.<strong> </strong></p><div class="g g-5"><div class="g-single a-6"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="8608536158"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
</p>			</div><!-- .entry-content -->

	<footer class="entry-footer col-xs-12">
		<div class="kawowo-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-112206" class="share-facebook sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-112206" class="share-twitter sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=%EF%BB%BFBashir%20Mutanda%20wants%20to%20keep%20improving%20https%3A%2F%2Fgoo.gl%2FXQXEb6" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow noopener noreferrer" data-shared="sharing-google-112206" class="share-google-plus-1 sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-112206" class="share-linkedin sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.kawowo.com/2018/12/16/%ef%bb%bfbashir-mutanda-wants-to-keep-improving/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div>	</footer><!-- .entry-footer -->

	</div><!-- .row -->

</article><!-- #post-## -->

						<div class="kawowo-related-posts col-md-12">
				<h3><span>You May Also Like</span></h3>
				<div class="row">
			 						<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://www.kawowo.com/2018/12/16/kcca-player-ratings-kcca-3-0-mtibwa-sugars-caf-cc/" title="KCCA Player Ratings: KCCA 3-0 Mtibwa Sugars | CAF CC" style="background: url( https://www.kawowo.com/wp-content/uploads/2018/12/jb-allan-kyambadde-kcca-vs-mtibwa-sugar-480x320.jpg ) center no-repeat;background-size: cover;"></a>
										 		<p><a href="https://www.kawowo.com/2018/12/16/kcca-player-ratings-kcca-3-0-mtibwa-sugars-caf-cc/" title="KCCA Player Ratings: KCCA 3-0 Mtibwa Sugars | CAF CC">KCCA Player Ratings: KCCA 3-0 Mtibwa Sugars | CAF CC</a></p>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://www.kawowo.com/2018/12/16/we-should-have-done-even-better-says-mike-mutebi/" title="We should have done even better, says Mike Mutebi" style="background: url( https://www.kawowo.com/wp-content/uploads/2018/12/jb-mike-mutebi-kcca-vs-express-480x320.jpg ) center no-repeat;background-size: cover;"></a>
										 		<p><a href="https://www.kawowo.com/2018/12/16/we-should-have-done-even-better-says-mike-mutebi/" title="We should have done even better, says Mike Mutebi">We should have done even better, says Mike Mutebi</a></p>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://www.kawowo.com/2018/12/16/afcon-2019-egypt-south-africa-bid-for-hosting-rights/" title="AFCON 2019: Egypt, South Africa bid for hosting rights" style="background: url( https://www.kawowo.com/wp-content/uploads/2017/06/cameroon-champs-480x320.jpg ) center no-repeat;background-size: cover;"></a>
										 		<p><a href="https://www.kawowo.com/2018/12/16/afcon-2019-egypt-south-africa-bid-for-hosting-rights/" title="AFCON 2019: Egypt, South Africa bid for hosting rights">AFCON 2019: Egypt, South Africa bid for hosting rights</a></p>
					</div>
								</div>
			</div>
		
			
			
<div id="comments" class="comments-area col-md-12">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/12/16/%EF%BB%BFbashir-mutanda-wants-to-keep-improving/#respond" style="display:none;">Cancel reply</a></small></span></h3>			<form action="https://www.kawowo.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" rows="1" aria-required="true" required="required" placeholder="Comment" ></textarea></p><div class="comment-fields"><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" aria-required="true" required="required" placeholder="Name" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" aria-required="true" required="required" placeholder="Email" /></p>
<p class="comment-form-ur"><label for="url">Website</label> <input id="url" name="url" type="url" value="" placeholder="Website" /></p></div>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='112206' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a1eaf71b6f" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="132"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

<div id="secondary" class="widget-area col-lg-4" role="complementary">
	<div class="theiaStickySidebar">
	<aside id="ajdg_bnnrwidgets-14" class="widget ajdg_bnnrwidgets"><div class="a-single a-14"><a href="http://clickmeterlink.com/tbet" target="_blank"><img src="https://www.kawowo.com/wp-content/uploads/2018/07/topbet_26072018.gif" /></a></div></aside><aside id="ajdg_bnnrwidgets-17" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Kawowo_sidebar_center -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="1792287653"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="facebook-likebox-2" class="widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/kawowosports" data-width="300"  data-height="300" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/kawowosports"><a href="https://www.facebook.com/kawowosports"></a></blockquote></div>
		</div>
		</aside><aside id="ajdg_bnnrwidgets-13" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Kawowo_sidebar_center -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="1792287653"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>
<aside id="wpp-2" class="widget popular-posts">
<h2 class="widget-title"><span>Popular</span></h2><!-- cached -->
<!-- WordPress Popular Posts -->
<ul class="fat-wpp-list"><li><div class="fat-wpp-image"><a href="https://www.kawowo.com/2018/12/15/live-kcca-vs-mtibwa-sugar-caf-confederation-cup/" title="FULL TIME: KCCA 3-0 Mtibwa Sugar | CAF Confederation Cup"><img width="480" height="320" src="https://www.kawowo.com/wp-content/uploads/2018/08/an-patrick-kaddu-kcca-2-480x320.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://www.kawowo.com/wp-content/uploads/2018/08/an-patrick-kaddu-kcca-2-480x320.jpg 480w, https://www.kawowo.com/wp-content/uploads/2018/08/an-patrick-kaddu-kcca-2-768x512.jpg 768w, https://www.kawowo.com/wp-content/uploads/2018/08/an-patrick-kaddu-kcca-2-300x200.jpg 300w, https://www.kawowo.com/wp-content/uploads/2018/08/an-patrick-kaddu-kcca-2-128x85.jpg 128w, https://www.kawowo.com/wp-content/uploads/2018/08/an-patrick-kaddu-kcca-2-32x21.jpg 32w, https://www.kawowo.com/wp-content/uploads/2018/08/an-patrick-kaddu-kcca-2.jpg 900w" sizes="(max-width: 480px) 100vw, 480px" /></a><div class="fat-wpp-image-cat"><a href="https://www.kawowo.com/category/football/">Football</a><span>&#124;</span><a href="https://www.kawowo.com/category/live/">Live</a></div></div><h2 class="entry-title"><a href="https://www.kawowo.com/2018/12/15/live-kcca-vs-mtibwa-sugar-caf-confederation-cup/" title="FULL TIME: KCCA 3-0 Mtibwa Sugar | CAF Confederation Cup">FULL TIME: KCCA 3-0 Mtibwa Sugar | CAF Confederation Cup</a></h2></li></ul>
</aside>
<aside id="ajdg_bnnrwidgets-2" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Kawowo_sidebar_center -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="1792287653"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="twitter_timeline-3" class="widget widget_twitter_timeline"><a class="twitter-timeline" data-width="320" data-height="300" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" href="https://twitter.com/KawowoSports" href="https://twitter.com/KawowoSports">My Tweets</a></aside><aside id="ajdg_bnnrwidgets-12" class="widget ajdg_bnnrwidgets"><div class="a-single a-10"><!-- Revive Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.1.3 -->
<ins data-revive-zoneid="10" data-revive-id="beba77153dbe07400da103c85884534b"></ins>
<script async src="//batraim.com/ads/www/delivery/asyncjs.php"></script></div></aside><aside id="ajdg_bnnrwidgets-8" class="widget ajdg_bnnrwidgets"><div class="a-single a-7"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Kawowo-Right-sidebar_bottom -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="3057147601"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="social_media_icons_widget_by_fat-4" class="widget widget_social_media_icons_widget_by_fat"><ul><li><a title="View kawowosports&#8217;s profile on Facebook" href="https://www.facebook.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Facebook</span><span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Twitter" href="https://twitter.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Twitter</span><span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Instagram" href="https://instagram.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Instagram</span><span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></span></a></li><li><a title="View kawowo&#8217;s profile on Google+" href="https://plus.google.com/u/0/+kawowo/" target="_blank"><span class="screen-reader-text">View kawowo&#8217;s profile on Google+</span><span><svg viewBox="0 0 36 28"><path d="M22.453 14.266q0 3.25-1.359 5.789t-3.875 3.969-5.766 1.43q-2.328 0-4.453-0.906t-3.656-2.438-2.438-3.656-0.906-4.453 0.906-4.453 2.438-3.656 3.656-2.438 4.453-0.906q4.469 0 7.672 3l-3.109 2.984q-1.828-1.766-4.562-1.766-1.922 0-3.555 0.969t-2.586 2.633-0.953 3.633 0.953 3.633 2.586 2.633 3.555 0.969q1.297 0 2.383-0.359t1.789-0.898 1.227-1.227 0.766-1.297 0.336-1.156h-6.5v-3.938h10.813q0.187 0.984 0.187 1.906zM36 12.359v3.281h-3.266v3.266h-3.281v-3.266h-3.266v-3.281h3.266v-3.266h3.281v3.266h3.266z"></path></svg></span></a></li></ul></aside>	</div>
</div><!-- #secondary -->
</div><!-- .row -->

	</div><!-- #content -->

			<div id="left-sidebar" class="left-sidebar-area">
				<div class="left-sidebar-content">
					<div class="left-header">
					<div class="left-logo">
						<a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png" class="custom-logo" alt="Kawowo Sports" itemprop="logo" srcset="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png 888w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-480x135.png 480w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-768x216.png 768w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-722x203.png 722w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-300x84.png 300w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-128x36.png 128w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-32x9.png 32w" sizes="(max-width: 888px) 100vw, 888px" /></a>					<button class="left-sidebar-close" title="Close"><svg><line stroke-miterlimit="10" x1="0.354" y1="0.354" x2="14.354" y2="14.354"/><line stroke-miterlimit="10" x1="14.354" y1="0.354" x2="0.354" y2="14.354"/></svg></button>
					</div>
					</div>
					<nav id="site-navigation" class="main-navigation" role="navigation">
								<div class="menu-mainmenu-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42339"><a href="https://www.kawowo.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42340"><a href="https://www.kawowo.com/category/football/">Football</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42346"><a href="https://www.kawowo.com/category/basketball/">Basketball</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42347"><a href="https://www.kawowo.com/category/rugby/">Rugby</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42350"><a href="https://www.kawowo.com/category/motorsport/">Motorsport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.kawowo.com/category/cricket/">Cricket</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42348"><a href="https://www.kawowo.com/category/athletics/">Athletics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42349"><a href="https://www.kawowo.com/category/golf/">Golf</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42345"><a>More</a><span class="expand-submenu" title="Expand">&#43;</span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42351"><a href="https://www.kawowo.com/category/pool/">Pool</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42343"><a href="https://www.kawowo.com/category/weightlifting/">Weightlifting</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42344"><a href="https://www.kawowo.com/category/volleyball/">Volleyball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82243"><a href="https://www.kawowo.com/category/chess/">Chess</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82244"><a href="https://www.kawowo.com/category/others/">Others</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82245"><a href="https://www.kawowo.com/category/boxing/">Boxing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82246"><a href="https://www.kawowo.com/category/cycling/">Cycling</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82247"><a href="https://www.kawowo.com/category/hockey/">Hockey</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82248"><a href="https://www.kawowo.com/category/lacrosse/">Lacrosse</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82249"><a href="https://www.kawowo.com/category/live/">Live</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82251"><a href="https://www.kawowo.com/category/rowing/">Rowing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82250"><a href="https://www.kawowo.com/category/netball/">Netball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82252"><a href="https://www.kawowo.com/category/swimming/">Swimming</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82253"><a href="https://www.kawowo.com/category/tennis/">Tennis</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110032"><a href="https://www.kawowo.com/category/american-football/">American Football</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42352"><a href="https://www.kawowo.com/category/opinion/">Op-eds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55773"><a>STATS</a><span class="expand-submenu" title="Expand">&#43;</span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55774"><a href="https://www.kawowo.com/table/2018-19-upl-table/">UPL Table Standings</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55783"><a href="https://www.kawowo.com/calendar/results/">All Results</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55780"><a href="https://www.kawowo.com/calendar/fixtures/">All Fixtures</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78030"><a href="https://www.kawowo.com/list/2018-19uganda-premier-league-top-scorers/">UPL top scorers</a></li>
</ul>
</li>
</ul></div>					</nav><!-- #site-navigation -->
					
<div id="tetriary" class="left-widget-area" role="complementary">
	<aside id="ajdg_bnnrwidgets-6" class="widget ajdg_bnnrwidgets"><div class="a-single a-14"><a href="http://clickmeterlink.com/tbet" target="_blank"><img src="https://www.kawowo.com/wp-content/uploads/2018/07/topbet_26072018.gif" /></a></div></aside></div><!-- #tetriary -->
					<div class="site-info">
			<p>© 2018 Kawowo Sports. All Rights reserved.</p>
<p>Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>					</div><!-- .site-info -->
				</div>
			</div>
		<div class="left-sidebar-bg">
		</div><!-- .left-sidebar-bg -->
			<div id="bottom-widget" class="widget-area container" role="complementary">
		<div class="row">
	    <aside id="ajdg_bnnrwidgets-10" class="widget col-xs-12 ajdg_bnnrwidgets"><div class="a-single a-5"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kaw-leaderboard -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="9585332407"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>		</div>
	</div><!-- #bottom-widget -->
		<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
		<a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png" class="custom-logo" alt="Kawowo Sports" itemprop="logo" srcset="https://www.kawowo.com/wp-content/uploads/2016/11/kww1.png 888w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-480x135.png 480w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-768x216.png 768w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-722x203.png 722w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-300x84.png 300w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-128x36.png 128w, https://www.kawowo.com/wp-content/uploads/2016/11/kww1-32x9.png 32w" sizes="(max-width: 888px) 100vw, 888px" /></a>				<a class="kawowo-extra-footer-image" href="http://owinosolutions.com/"><img src="https://www.kawowo.com/wp-content/uploads/2016/11/owino1-e1478170366337.jpg" alt=""></a>
			<p>© 2018 Kawowo Sports. All Rights reserved.</p>
<p>Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

		<script type="text/javascript">
					 _sf_async_config.authors = "Ismael Kiyonga";
			_sf_async_config.sections = "Football";
					(function(){
			        function loadChartbeat() {
					window._sf_endpt=(new Date()).getTime();
					var e = document.createElement('script');
					e.setAttribute('language', 'javascript');
					e.setAttribute('type', 'text/javascript');
					e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
					document.body.appendChild(e);
				  }
				  var oldonload = window.onload;
				  window.onload = (typeof window.onload != 'function') ?
					 loadChartbeat : function() { try { oldonload(); } catch (e) { loadChartbeat(); throw e} loadChartbeat(); };
				})();
		</script>
	<div style="display:none">
	<div class="grofile-hash-map-27b5cc4e8b9a4bcc9b25568befc5d06f">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.kawowo.com\/2018\/12\/16\/%ef%bb%bfbashir-mutanda-wants-to-keep-improving\/":112206};
	</script>
				<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.kawowo.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201850'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/js/jquery.dataTables.min.js?ver=1.10.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var localized_strings = {"days":"days","hrs":"hrs","mins":"mins","secs":"secs","previous":"Previous","next":"Next"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress/assets/js/sportspress.js?ver=2.6.14'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-match-stats/js/jquery.waypoints.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-match-stats/js/sportspress-match-stats.js?ver=2.2'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-scoreboard/js/sportspress-scoreboard.js?ver=1544974596'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-sponsors/js/sportspress-sponsors.js?ver=1544974596'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/sportspress-pro/includes/sportspress-tournaments/js/sportspress-tournaments.js?ver=2.6.14'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Decaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/slick/slick.min.js?ver=20150828'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/js/theia-sticky-sidebar.min.js?ver=1.2.2'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/js/jquery.magnific-popup.min.js?ver=20150829'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/ui/effect-slide.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var kawowo = {"home_page_slider_img_number":"1","loadMoreText":"Load more posts","loadingText":" ","noMorePostsText":"No More Posts","expandText":"Expand","closeText":"Close","startPage":"1","maxPages":"0","nextLink":null,"pagination":"infinite","getTemplateDirectoryUri":"https:\/\/www.kawowo.com\/wp-content\/themes\/kawowo-sports","months":["January","February","March","April","May","June","July","August","September","October","November","December"],"days":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/js/kawowo.min.js?ver=20160908'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/themes/kawowo-sports/js/skip-link-focus-fix.min.js?ver=20130115'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=6.8.1'></script>
<script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script async="async" type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kawowo.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.8.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
			<script type="text/javascript">
			jQuery(document).ready( function($) {
				$('.sp-header-loaded').prepend( $('.sp-league-menu') );
			} );
			</script>
					<script type="text/javascript">
			jQuery(document).ready( function($) {
				$('.sp-header-loaded').prepend( $('.sp-header-scoreboard') );
			} );
			</script>
		
</body>
</html>
