<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://www.kawowo.com/xmlrpc.php"><link type="text/css" media="all" href="https://www.kawowo.com/wp-content/cache/autoptimize/css/autoptimize_7b2f47671696b5c374166c48906941ff.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.kawowo.com/wp-content/cache/autoptimize/css/autoptimize_ad392cd23785017881bd74e68c4ede31.css" rel="stylesheet" /><title>Latest professional golfer Deco Mutebi sets personal targets</title><link rel="canonical" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Latest professional golfer Deco Mutebi sets personal targets" /><meta property="og:description" content="Herman &#8216;Deco&#8217; Mutebi, 19, is among the two latest golfers to be assimilated into the Uganda Professional Golf Association (UPGA). The Entebbe Street Club sponsored golfer was finally admitted as a professional golfer after successful application, alongside Uganda Golf Club&#8217;s Becca Mwanja. Born and raised in Entebbe, Mutebi is a former footballer who has been &hellip;" /><meta property="og:url" content="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/" /><meta property="og:site_name" content="Kawowo Sports" /><meta property="article:publisher" content="https://www.facebook.com/kawowosports" /><meta property="article:author" content="https://www.facebook.com/isabirye.david.96" /><meta property="article:section" content="Golf" /><meta property="article:published_time" content="2019-02-25T00:23:15+00:00" /><meta property="og:image" content="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=756%2C600&#038;ssl=1" /><meta property="og:image:secure_url" content="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=756%2C600&#038;ssl=1" /><meta property="og:image:width" content="756" /><meta property="og:image:height" content="600" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Herman &#8216;Deco&#8217; Mutebi, 19, is among the two latest golfers to be assimilated into the Uganda Professional Golf Association (UPGA). The Entebbe Street Club sponsored golfer was finally admitted as a professional golfer after successful application, alongside Uganda Golf Club&#8217;s Becca Mwanja. Born and raised in Entebbe, Mutebi is a former footballer who has been [&hellip;]" /><meta name="twitter:title" content="Latest professional golfer Deco Mutebi sets personal targets" /><meta name="twitter:site" content="@KawowoSports" /><meta name="twitter:image" content="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=756%2C600&#038;ssl=1" /><meta name="twitter:creator" content="@IsabiryeDavid" /> <script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://www.kawowo.com/","sameAs":["https://www.facebook.com/kawowosports","https://www.instagram.com/kawowosports/","https://www.youtube.com/c/Kawowo","https://twitter.com/KawowoSports"],"@id":"https://www.kawowo.com/#organization","name":"Kawowo Sports","logo":"http://www.kawowo.com/wp-content/uploads/2016/11/kww1.png"}</script> <link rel='dns-prefetch' href='//s0.wp.com' /><link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Feed" href="https://www.kawowo.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Comments Feed" href="https://www.kawowo.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Latest professional golfer Deco Mutebi sets personal targets Comments Feed" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.4.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-20862137-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-20862137-4', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <link rel='stylesheet' id='advgb_custom_styles-css'  href='https://www.kawowo.com/wp-content/cache/autoptimize/css/autoptimize_single_a4d9bdc62301921041d50a8a66c90f16.css' type='text/css' media='all' /><link rel='stylesheet' id='dashicons-css'  href='https://www.kawowo.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' /><link crossorigin="anonymous" rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=5.0.3' type='text/css' media='all' /> <script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/www.kawowo.com","hash_tracking":"false"};</script> <script type='text/javascript'>var wpp_params = {"sampling_active":"1","sampling_rate":"10","ajax_url":"https:\/\/www.kawowo.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"116647","token":"fdca7dcfc7","debug":""};</script> <link rel='https://api.w.org/' href='https://www.kawowo.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.kawowo.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.kawowo.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.0.3" /><meta name="generator" content="SportsPress 2.6.14" /><meta name="generator" content="SportsPress Pro 2.6.14" /><link rel='shortlink' href='https://goo.gl/1ssEjF' /><link rel="alternate" type="application/json+oembed" href="https://www.kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kawowo.com%2F2019%2F02%2F25%2Flatest-professional-golfer-deco-mutebi-sets-personal-targets%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kawowo.com%2F2019%2F02%2F25%2Flatest-professional-golfer-deco-mutebi-sets-personal-targets%2F&#038;format=xml" />  <script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script> <script type="text/javascript">var _sf_async_config = _sf_async_config || {};
			_sf_async_config.uid = 65763;
			_sf_async_config.domain = "kawowo.com";
			_sf_async_config.useCanonical = true;</script> <script src="//static.chartbeat.com/js/chartbeat_mab.js"></script> <meta property="fb:pages" content="145227195529292" /><link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel='dns-prefetch' href='//widgets.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/amp/"><link rel="icon" href="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg?fit=160%2C160&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg?fit=160%2C160&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg?fit=160%2C160&#038;ssl=1" /></head><body class="post-template-default single single-post postid-116647 single-format-standard wp-custom-logo group-blog"><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header" role="banner"><nav id="top-navigation" class="navbar-navigation" role="navigation"> <button id="left-navbar-toggle" class="menu-toggle" aria-controls="left-sidebar" aria-expanded="false"><span class="screen-reader-text">Menu</span><svg><path d="M3 6h18v2.016h-18v-2.016zM3 12.984v-1.969h18v1.969h-18zM3 18v-2.016h18v2.016h-18z"></path></svg></button> <button id="navbar-search-toggle" class="search-toggle" aria-controls="search-panel" aria-expanded="false"><span class="screen-reader-text">Search</span><svg><path d="M9.516 14.016q1.875 0 3.188-1.313t1.313-3.188-1.313-3.188-3.188-1.313-3.188 1.313-1.313 3.188 1.313 3.188 3.188 1.313zM15.516 14.016l4.969 4.969-1.5 1.5-4.969-4.969v-0.797l-0.281-0.281q-1.781 1.547-4.219 1.547-2.719 0-4.617-1.875t-1.898-4.594 1.898-4.617 4.617-1.898 4.594 1.898 1.875 4.617q0 2.438-1.547 4.219l0.281 0.281h0.797z"></path></svg></button><div id="search-panel" class="kawowo-search-panel"> <button class="kawowo-search-panel-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button><form role="search" method="get" class="search-form" action="https://www.kawowo.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Type and hit enter" value="" name="s" title="Search for:" /> </label> <input type="submit" class="search-submit" value="Search" /></form></div><div id="menu-social-widget" class="widget-area menu-social-widget" role="complementary"><aside id="social_media_icons_widget_by_fat-3" class="widget widget_social_media_icons_widget_by_fat"><ul><li><a title="View kawowosports&#8217;s profile on Facebook" href="https://www.facebook.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Facebook</span><span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Twitter" href="https://twitter.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Twitter</span><span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></span></a></li><li><a title="View KawowoSports&#8217;s profile on Instagram" href="https://instagram.com/KawowoSports/" target="_blank"><span class="screen-reader-text">View KawowoSports&#8217;s profile on Instagram</span><span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></span></a></li><li><a title="View Kawowo&#8217;s profile on Google+" href="https://plus.google.com/u/0/+Kawowo/" target="_blank"><span class="screen-reader-text">View Kawowo&#8217;s profile on Google+</span><span><svg viewBox="0 0 36 28"><path d="M22.453 14.266q0 3.25-1.359 5.789t-3.875 3.969-5.766 1.43q-2.328 0-4.453-0.906t-3.656-2.438-2.438-3.656-0.906-4.453 0.906-4.453 2.438-3.656 3.656-2.438 4.453-0.906q4.469 0 7.672 3l-3.109 2.984q-1.828-1.766-4.562-1.766-1.922 0-3.555 0.969t-2.586 2.633-0.953 3.633 0.953 3.633 2.586 2.633 3.555 0.969q1.297 0 2.383-0.359t1.789-0.898 1.227-1.227 0.766-1.297 0.336-1.156h-6.5v-3.938h10.813q0.187 0.984 0.187 1.906zM36 12.359v3.281h-3.266v3.266h-3.281v-3.266h-3.266v-3.281h3.266v-3.266h3.281v3.266h3.266z"></path></svg></span></a></li></ul></aside></div><div class="menu-logo"> <a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kawowo Sports" itemprop="logo" data-attachment-id="21152" data-permalink="https://www.kawowo.com/kww1/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" data-orig-size="888,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Kawowo Sports" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=480%2C135&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=722%2C203&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?w=888&amp;ssl=1 888w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=480%2C135&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=768%2C216&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=722%2C203&amp;ssl=1 722w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=300%2C84&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=128%2C36&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=32%2C9&amp;ssl=1 32w" data-lazy-sizes="(max-width: 888px) 100vw, 888px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div><div class="menu-mainmenu-container"><ul id="top-menu" class="menu"><li id="menu-item-42339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42339"><a href="https://www.kawowo.com">Home</a></li><li id="menu-item-42340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42340"><a href="https://www.kawowo.com/football/">Football</a></li><li id="menu-item-42346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42346"><a href="https://www.kawowo.com/basketball/">Basketball</a></li><li id="menu-item-42347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42347"><a href="https://www.kawowo.com/rugby/">Rugby</a></li><li id="menu-item-42350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42350"><a href="https://www.kawowo.com/motorsport/">Motorsport</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.kawowo.com/cricket/">Cricket</a></li><li id="menu-item-42348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42348"><a href="https://www.kawowo.com/athletics/">Athletics</a></li><li id="menu-item-42349" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42349"><a href="https://www.kawowo.com/golf/">Golf</a></li><li id="menu-item-42345" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42345"><a>More</a><span class="expand-submenu" title="Expand">&#43;</span><ul class="sub-menu"><li id="menu-item-42351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42351"><a href="https://www.kawowo.com/pool/">Pool</a></li><li id="menu-item-42343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42343"><a href="https://www.kawowo.com/weightlifting/">Weightlifting</a></li><li id="menu-item-42344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42344"><a href="https://www.kawowo.com/volleyball/">Volleyball</a></li><li id="menu-item-82243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82243"><a href="https://www.kawowo.com/chess/">Chess</a></li><li id="menu-item-82244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82244"><a href="https://www.kawowo.com/others/">Others</a></li><li id="menu-item-82245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82245"><a href="https://www.kawowo.com/boxing/">Boxing</a></li><li id="menu-item-82246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82246"><a href="https://www.kawowo.com/cycling/">Cycling</a></li><li id="menu-item-82247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82247"><a href="https://www.kawowo.com/hockey/">Hockey</a></li><li id="menu-item-82248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82248"><a href="https://www.kawowo.com/lacrosse/">Lacrosse</a></li><li id="menu-item-82249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82249"><a href="https://www.kawowo.com/live/">Live</a></li><li id="menu-item-82251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82251"><a href="https://www.kawowo.com/rowing/">Rowing</a></li><li id="menu-item-82250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82250"><a href="https://www.kawowo.com/netball/">Netball</a></li><li id="menu-item-82252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82252"><a href="https://www.kawowo.com/swimming/">Swimming</a></li><li id="menu-item-82253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82253"><a href="https://www.kawowo.com/tennis/">Tennis</a></li><li id="menu-item-110032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110032"><a href="https://www.kawowo.com/american-football/">American Football</a></li></ul></li><li id="menu-item-42352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42352"><a href="https://www.kawowo.com/opinion/">Op-eds</a></li><li id="menu-item-55773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55773"><a>STATS</a><span class="expand-submenu" title="Expand">&#43;</span><ul class="sub-menu"><li id="menu-item-55774" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55774"><a href="https://www.kawowo.com/table/2018-19-upl-table/">UPL Table Standings</a></li><li id="menu-item-55783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55783"><a href="https://www.kawowo.com/calendar/results/">All Results</a></li><li id="menu-item-55780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55780"><a href="https://www.kawowo.com/calendar/fixtures/">All Fixtures</a></li><li id="menu-item-78030" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78030"><a href="https://www.kawowo.com/list/2018-19uganda-premier-league-top-scorers/">UPL top scorers</a></li></ul></li></ul></div></nav></header><div id="content" class="site-content container"><div class="row"><div id="top-ads-widget" class="widget-area col-xs-12" role="complementary"><aside id="ajdg_bnnrwidgets-7" class="widget ajdg_bnnrwidgets"><div class="a-single a-1"> <ins data-revive-zoneid="9" data-revive-id="beba77153dbe07400da103c85884534b"></ins> <script async src="//batraim.com/ads/www/delivery/asyncjs.php"></script> </div></aside></div></div><div class="row"><div id="primary" class="content-area col-lg-8"><main id="main" class="site-main row" role="main"><article id="post-116647" class="col-md-12 post-116647 post type-post status-publish format-standard has-post-thumbnail hentry category-golf"><header class="entry-header row"><div class="single-header col-xs-12"><div class="category-list"> <a href="https://www.kawowo.com/golf/">Golf</a></div><h1 class="entry-title">Latest professional golfer Deco Mutebi sets personal targets</h1></div><div class="col-xs-12 col-sm-8 col-sm-push-4 col-md-9 col-md-push-3 col-lg-9 col-lg-push-3 col-xl-10 col-xl-push-2"><div class="kawowo-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-116647" class="share-facebook sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-116647" class="share-twitter sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=Latest%20professional%20golfer%20Deco%20Mutebi%20sets%20personal%20targets%20https%3A%2F%2Fgoo.gl%2F1ssEjF" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-116647" class="share-linkedin sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div><div class="entry-meta"> <span class="posted-on"><a href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/" rel="bookmark"><time class="entry-date published updated" datetime="2019-02-25T03:23:15+00:00">2 hours</time></a> ago</span><br/><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://www.kawowo.com/author/david/">David Isabirye</a></span></span></div></div><div class='author-avatar-wrapper col-xs-12 col-sm-4 col-sm-pull-8 col-md-3 col-md-pull-9 col-xl-2 col-xl-pull-10'><div class="author-avatar"><img alt src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&#038;d=mm&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" data-lazy-srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=192&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript></div><div class="kawowo-author-social-icons"><a href="https://twitter.com/IsabiryeDavid" title="Twitter" target="_blank"><span class="screen-reader-text">Twitter</span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></a><a href="https://www.facebook.com/isabirye.david.96" title="Facebook" target="_blank"><span class="screen-reader-text">Facebook</span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></a><a href="https://www.instagram.com/davidisabirye" title="Instagram" target="_blank"><span class="screen-reader-text">Instagram</span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></a></div></div></header><div class="row"><div class="entry-content col-xs-12 col-lg-10 col-lg-push-2"><figure class="wp-block-image"><img data-attachment-id="116648" data-permalink="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/herman-deco-mutebi2/" data-orig-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=756%2C600&amp;ssl=1" data-orig-size="756,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;Batanudde-John&quot;,&quot;camera&quot;:&quot;Canon EOS 7D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1537456657&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;200&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Herman Deco Mutebi2" data-image-description data-medium-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=480%2C381&amp;ssl=1" data-large-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=692%2C549&amp;ssl=1" src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=692%2C549&#038;ssl=1" alt class="wp-image-116648 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?w=756&amp;ssl=1 756w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=480%2C381&amp;ssl=1 480w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=300%2C238&amp;ssl=1 300w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=128%2C102&amp;ssl=1 128w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=32%2C25&amp;ssl=1 32w" data-lazy-sizes="(max-width: 692px) 100vw, 692px" data-lazy-src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=692%2C549&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="116648" data-permalink="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/herman-deco-mutebi2/" data-orig-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=756%2C600&amp;ssl=1" data-orig-size="756,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;Batanudde-John&quot;,&quot;camera&quot;:&quot;Canon EOS 7D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1537456657&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;200&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.001&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Herman Deco Mutebi2" data-image-description="" data-medium-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=480%2C381&amp;ssl=1" data-large-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?fit=692%2C549&amp;ssl=1" src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=692%2C549&#038;ssl=1" alt="" class="wp-image-116648" srcset="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?w=756&amp;ssl=1 756w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=480%2C381&amp;ssl=1 480w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=300%2C238&amp;ssl=1 300w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=128%2C102&amp;ssl=1 128w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi2.jpg?resize=32%2C25&amp;ssl=1 32w" sizes="(max-width: 692px) 100vw, 692px" data-recalc-dims="1" /></noscript><figcaption>Herman &#8216;Deco&#8217; Mutebi recently joined the professional ranks</figcaption></figure><p><strong>Herman &#8216;Deco&#8217; Mutebi, 19, is among the two latest golfers to be assimilated into the Uganda Professional Golf Association (UPGA).</strong></p><p>The Entebbe Street Club sponsored golfer was finally admitted as a professional golfer after successful application, alongside Uganda Golf Club&#8217;s Becca Mwanja.</p><p>Born and raised in Entebbe, Mutebi is a former footballer who has been part of the Uganda national team for three years.</p><div class="g g-1"><div class="g-single a-14"><a href="http://clickmeterlink.com/tbet" target="_blank"><img src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019a.gif?w=692&#038;ssl=1" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019a.gif?w=692&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019a.gif?w=692&#038;ssl=1" data-recalc-dims="1" /></noscript></a></div></div><p>He finally made the decision to turn professional after near miss to win the coveted Uganda Amateurs Golf Open championship last year.</p><div class="wp-block-image"><figure class="aligncenter"><img data-attachment-id="107348" data-permalink="https://www.kawowo.com/2018/09/23/phenomenal-otile-seals-treble-of-uganda-amateur-golf-titles-on-his-birthday/herman-deco-mutebi-gestures-during-the-final-round-in-entebbe-he-finished-fourth-overall/" data-orig-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?fit=400%2C600&amp;ssl=1" data-orig-size="400,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;Batanudde-John&quot;,&quot;camera&quot;:&quot;Canon EOS 7D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1537631263&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;200&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Herman Deco Mutebi gestures during the final round in Entebbe. He finished fourth overall" data-image-description data-medium-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?fit=400%2C600&amp;ssl=1" data-large-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?fit=400%2C600&amp;ssl=1" src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=400%2C600&#038;ssl=1" alt class="wp-image-107348 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?w=400&amp;ssl=1 400w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=200%2C300&amp;ssl=1 200w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=85%2C128&amp;ssl=1 85w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=21%2C32&amp;ssl=1 21w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=400%2C600&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="107348" data-permalink="https://www.kawowo.com/2018/09/23/phenomenal-otile-seals-treble-of-uganda-amateur-golf-titles-on-his-birthday/herman-deco-mutebi-gestures-during-the-final-round-in-entebbe-he-finished-fourth-overall/" data-orig-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?fit=400%2C600&amp;ssl=1" data-orig-size="400,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;Batanudde-John&quot;,&quot;camera&quot;:&quot;Canon EOS 7D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1537631263&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;200&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Herman Deco Mutebi gestures during the final round in Entebbe. He finished fourth overall" data-image-description="" data-medium-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?fit=400%2C600&amp;ssl=1" data-large-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?fit=400%2C600&amp;ssl=1" src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=400%2C600&#038;ssl=1" alt="" class="wp-image-107348" srcset="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?w=400&amp;ssl=1 400w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=200%2C300&amp;ssl=1 200w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=85%2C128&amp;ssl=1 85w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2018/09/Herman-Deco-Mutebi-gestures-during-the-final-round-in-Entebbe.-He-finished-fourth-overall.jpg?resize=21%2C32&amp;ssl=1 21w" sizes="(max-width: 400px) 100vw, 400px" data-recalc-dims="1" /></noscript><figcaption>Deco Mutebi gestures after tee-off on the 10th tee box at Entebbe Golf Club.</figcaption></figure></div><p>Deco, as he is fondly known in the golfing circles has already set personal targets.</p><blockquote class="wp-block-quote"><p>First of all, I want to thank the Uganda Professional Golf Association (UPGA) for positively accepting my application. I thank my sponsor (Street Club), the Uganda Golf Union, Entebbe Golf Club and all personalities who have helped me in my golfing journey. Professional golf is a full time commitment and I am ready to battle. This is my life now. I have to train every day with doubled and tripped efforts.</p><div class="g g-4"><div class="g-single a-6"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
 style="display:block; text-align:center;"
 data-ad-layout="in-article"
 data-ad-format="fluid"
 data-ad-client="ca-pub-0521644691090227"
 data-ad-slot="8608536158"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><cite>Herman Deco Mutebi, Professional Golfer</cite></blockquote><figure class="wp-block-image"><img data-attachment-id="116649" data-permalink="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/herman-deco-mutebi/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=871%2C600&amp;ssl=1" data-orig-size="871,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Batanudde-John&quot;,&quot;camera&quot;:&quot;Canon EOS 7D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1537533750&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;176&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Herman Deco Mutebi" data-image-description data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=480%2C331&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=692%2C477&amp;ssl=1" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=871%2C600&amp;ssl=1" alt class="wp-image-116649 jetpack-lazy-image" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?w=871&amp;ssl=1 871w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=480%2C331&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=768%2C529&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=300%2C207&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=128%2C88&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=32%2C22&amp;ssl=1 32w" data-lazy-sizes="(max-width: 692px) 100vw, 692px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=871%2C600&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="116649" data-permalink="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/herman-deco-mutebi/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=871%2C600&amp;ssl=1" data-orig-size="871,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Batanudde-John&quot;,&quot;camera&quot;:&quot;Canon EOS 7D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1537533750&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;176&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Herman Deco Mutebi" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=480%2C331&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=692%2C477&amp;ssl=1" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?fit=871%2C600&amp;ssl=1" alt="" class="wp-image-116649" srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?w=871&amp;ssl=1 871w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=480%2C331&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=768%2C529&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=300%2C207&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=128%2C88&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Herman-Deco-Mutebi.jpg?resize=32%2C22&amp;ssl=1 32w" sizes="(max-width: 692px) 100vw, 692px" /></noscript><figcaption>Deco Mutebi follows his ball in flight after a shot at Entebbe Golf Club.</figcaption></figure><blockquote class="wp-block-quote"><p>Everyday is a learning curve for me. I will learn a lot from the senior professional golfers.</p><cite>Deco Herman Mutebi, Professional Golfer</cite></blockquote><p>Mutebi is one of the youngest professionals in the sport with Tooro Golf Club&#8217;s David Kamulindwa Amooti the other in this age bracket.</p><div class="g g-5"><div class="g-single a-6"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
 style="display:block; text-align:center;"
 data-ad-layout="in-article"
 data-ad-format="fluid"
 data-ad-client="ca-pub-0521644691090227"
 data-ad-slot="8608536158"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><p>The UPGA has over 45 professional golfers registered with the association.</p><p>A number of tournaments (locally and in the region) await these golfers this year.</p><p>The on-going Tusker Malt Golfer series, Singleton Match play series, Entebbe Open, JBG Open, Kakira Open, Uganda Open, Pepsi Independence Open among others are some of the domestic tours.</p></div><footer class="entry-footer col-xs-12"><div class="kawowo-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-116647" class="share-facebook sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-116647" class="share-twitter sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=Latest%20professional%20golfer%20Deco%20Mutebi%20sets%20personal%20targets%20https%3A%2F%2Fgoo.gl%2F1ssEjF" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-116647" class="share-linkedin sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.kawowo.com/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></footer></div></article><div class="kawowo-related-posts col-md-12"><h3><span>You May Also Like</span></h3><div class="row"><div class="col-xs-12 col-md-4"> <a class="related-posts-thumbnail" href="https://www.kawowo.com/2019/02/25/serene-lake-victoria-serena-course-hosts-penultimate-tusker-malt-lager-golf-series/" title="Serene Lake Victoria Serena course hosts penultimate Tusker Malt Lager Golf series" style="background: url( https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/02/an-golfer-tuskermalt-series-1.jpg?fit=480%2C320&#038;ssl=1 ) center no-repeat;background-size: cover;"></a><p><a href="https://www.kawowo.com/2019/02/25/serene-lake-victoria-serena-course-hosts-penultimate-tusker-malt-lager-golf-series/" title="Serene Lake Victoria Serena course hosts penultimate Tusker Malt Lager Golf series">Serene Lake Victoria Serena course hosts penultimate Tusker Malt Lager Golf series</a></p></div><div class="col-xs-12 col-md-4"> <a class="related-posts-thumbnail" href="https://www.kawowo.com/2019/02/23/ndyaguma-bulafu-and-orach-tipped-ahead-of-tusker-golf-series-leg-at-serena/" title="Ndyaguma, Bulafu and Orach tipped ahead of Tusker Golf series leg at Serena" style="background: url( https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/10/Sponsors-Tusker-malt-series.jpg?fit=480%2C318&#038;ssl=1 ) center no-repeat;background-size: cover;"></a><p><a href="https://www.kawowo.com/2019/02/23/ndyaguma-bulafu-and-orach-tipped-ahead-of-tusker-golf-series-leg-at-serena/" title="Ndyaguma, Bulafu and Orach tipped ahead of Tusker Golf series leg at Serena">Ndyaguma, Bulafu and Orach tipped ahead of Tusker Golf series leg at Serena</a></p></div><div class="col-xs-12 col-md-4"> <a class="related-posts-thumbnail" href="https://www.kawowo.com/2019/02/19/singleton-golf-challenge-2019-32-pairs-progress-to-round-two/" title="Singleton Golf Challenge: 32 pairs progress to round two" style="background: url( https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Group-golfers-Singleton-round-one-2019.jpg?fit=480%2C320&#038;ssl=1 ) center no-repeat;background-size: cover;"></a><p><a href="https://www.kawowo.com/2019/02/19/singleton-golf-challenge-2019-32-pairs-progress-to-round-two/" title="Singleton Golf Challenge: 32 pairs progress to round two">Singleton Golf Challenge: 32 pairs progress to round two</a></p></div></div></div><div id="comments" class="comments-area col-md-12"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/02/25/latest-professional-golfer-deco-mutebi-sets-personal-targets/#respond" style="display:none;">Cancel reply</a></small></span></h3><form action="https://www.kawowo.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" rows="1" aria-required="true" required="required" placeholder="Comment" ></textarea></p><div class="comment-fields"><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" aria-required="true" required="required" placeholder="Name" /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" aria-required="true" required="required" placeholder="Email" /></p><p class="comment-form-ur"><label for="url">Website</label> <input id="url" name="url" type="url" value="" placeholder="Website" /></p></div><p class="form-submit"><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='116647' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></main></div><div id="secondary" class="widget-area col-lg-4" role="complementary"><div class="theiaStickySidebar"><aside id="ajdg_bnnrwidgets-14" class="widget ajdg_bnnrwidgets"><div class="a-single a-14"><a href="http://clickmeterlink.com/tbet" target="_blank"><img src="https://www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019a.gif" /></a></div></aside><aside id="ajdg_bnnrwidgets-17" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:336px;height:280px"
 data-ad-client="ca-pub-0521644691090227"
 data-ad-slot="1792287653"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="facebook-likebox-2" class="widget widget_facebook_likebox"><div id="fb-root"></div><div class="fb-page" data-href="https://www.facebook.com/kawowosports" data-width="300"  data-height="300" data-hide-cover="false" data-show-facepile="false" data-show-posts="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/kawowosports"><a href="https://www.facebook.com/kawowosports"></a></blockquote></div></div></aside><aside id="ajdg_bnnrwidgets-13" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:336px;height:280px"
 data-ad-client="ca-pub-0521644691090227"
 data-ad-slot="1792287653"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="wpp-2" class="widget popular-posts"><h2 class="widget-title"><span>Popular</span></h2><ul class="fat-wpp-list"><li><div class="fat-wpp-image"><a href="https://www.kawowo.com/2019/02/24/mugerwa-joins-third-ethiopian-club-under-3-years/" title="Yassar Mugerwa joins third Ethiopian Premier Club"><img width="480" height="320" src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?fit=480%2C320&amp;ssl=1" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="116561" data-permalink="https://www.kawowo.com/2019/02/23/uganda-cranes-midfielder-mugerwa-mutually-terminates-contract-at-ethiopian-club/yassar-mugerwa-shoots/" data-orig-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?fit=960%2C640&amp;ssl=1" data-orig-size="960,640" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Yassar Mugerwa shoots" data-image-description="" data-medium-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?fit=480%2C320&amp;ssl=1" data-large-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?fit=692%2C461&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?w=960&amp;ssl=1 960w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?resize=480%2C320&amp;ssl=1 480w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?resize=900%2C600&amp;ssl=1 900w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?resize=128%2C85&amp;ssl=1 128w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?resize=32%2C21&amp;ssl=1 32w" data-lazy-sizes="(max-width: 480px) 100vw, 480px" data-lazy-src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/02/Yassar-Mugerwa-shoots.jpg?fit=480%2C320&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><div class="fat-wpp-image-cat"><a href="https://www.kawowo.com/football/">Football</a></div></div><h2 class="entry-title"><a href="https://www.kawowo.com/2019/02/24/mugerwa-joins-third-ethiopian-club-under-3-years/" title="Yassar Mugerwa joins third Ethiopian Premier Club">Yassar Mugerwa joins third Ethiopian Premier Club</a></h2></li></ul></aside><aside id="ajdg_bnnrwidgets-2" class="widget ajdg_bnnrwidgets"><div class="a-single a-4"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:336px;height:280px"
 data-ad-client="ca-pub-0521644691090227"
 data-ad-slot="1792287653"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="twitter_timeline-3" class="widget widget_twitter_timeline"><a class="twitter-timeline" data-width="320" data-height="300" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" href="https://twitter.com/KawowoSports" href="https://twitter.com/KawowoSports">My Tweets</a></aside><aside id="ajdg_bnnrwidgets-12" class="widget ajdg_bnnrwidgets"><div class="a-single a-10"> <ins data-revive-zoneid="10" data-revive-id="beba77153dbe07400da103c85884534b"></ins> <script async src="//batraim.com/ads/www/delivery/asyncjs.php"></script></div></aside><aside id="ajdg_bnnrwidgets-8" class="widget ajdg_bnnrwidgets"><div class="a-single a-7"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:336px;height:280px"
 data-ad-client="ca-pub-0521644691090227"
 data-ad-slot="3057147601"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="social_media_icons_widget_by_fat-4" class="widget widget_social_media_icons_widget_by_fat"><ul><li><a title="View kawowosports&#8217;s profile on Facebook" href="https://www.facebook.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Facebook</span><span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Twitter" href="https://twitter.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Twitter</span><span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></span></a></li><li><a title="View kawowosports&#8217;s profile on Instagram" href="https://instagram.com/kawowosports/" target="_blank"><span class="screen-reader-text">View kawowosports&#8217;s profile on Instagram</span><span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></span></a></li><li><a title="View kawowo&#8217;s profile on Google+" href="https://plus.google.com/u/0/+kawowo/" target="_blank"><span class="screen-reader-text">View kawowo&#8217;s profile on Google+</span><span><svg viewBox="0 0 36 28"><path d="M22.453 14.266q0 3.25-1.359 5.789t-3.875 3.969-5.766 1.43q-2.328 0-4.453-0.906t-3.656-2.438-2.438-3.656-0.906-4.453 0.906-4.453 2.438-3.656 3.656-2.438 4.453-0.906q4.469 0 7.672 3l-3.109 2.984q-1.828-1.766-4.562-1.766-1.922 0-3.555 0.969t-2.586 2.633-0.953 3.633 0.953 3.633 2.586 2.633 3.555 0.969q1.297 0 2.383-0.359t1.789-0.898 1.227-1.227 0.766-1.297 0.336-1.156h-6.5v-3.938h10.813q0.187 0.984 0.187 1.906zM36 12.359v3.281h-3.266v3.266h-3.281v-3.266h-3.266v-3.281h3.266v-3.266h3.281v3.266h3.266z"></path></svg></span></a></li></ul></aside></div></div></div></div><div id="left-sidebar" class="left-sidebar-area"><div class="left-sidebar-content"><div class="left-header"><div class="left-logo"> <a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kawowo Sports" itemprop="logo" data-attachment-id="21152" data-permalink="https://www.kawowo.com/kww1/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" data-orig-size="888,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Kawowo Sports" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=480%2C135&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=692%2C195&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?w=888&amp;ssl=1 888w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=480%2C135&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=768%2C216&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=722%2C203&amp;ssl=1 722w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=300%2C84&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=128%2C36&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=32%2C9&amp;ssl=1 32w" data-lazy-sizes="(max-width: 888px) 100vw, 888px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a> <button class="left-sidebar-close" title="Close"><svg><line stroke-miterlimit="10" x1="0.354" y1="0.354" x2="14.354" y2="14.354"/><line stroke-miterlimit="10" x1="14.354" y1="0.354" x2="0.354" y2="14.354"/></svg></button></div></div><nav id="site-navigation" class="main-navigation" role="navigation"><div class="menu-mainmenu-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42339"><a href="https://www.kawowo.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42340"><a href="https://www.kawowo.com/football/">Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42346"><a href="https://www.kawowo.com/basketball/">Basketball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42347"><a href="https://www.kawowo.com/rugby/">Rugby</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42350"><a href="https://www.kawowo.com/motorsport/">Motorsport</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.kawowo.com/cricket/">Cricket</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42348"><a href="https://www.kawowo.com/athletics/">Athletics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42349"><a href="https://www.kawowo.com/golf/">Golf</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42345"><a>More</a><span class="expand-submenu" title="Expand">&#43;</span><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42351"><a href="https://www.kawowo.com/pool/">Pool</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42343"><a href="https://www.kawowo.com/weightlifting/">Weightlifting</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42344"><a href="https://www.kawowo.com/volleyball/">Volleyball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82243"><a href="https://www.kawowo.com/chess/">Chess</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82244"><a href="https://www.kawowo.com/others/">Others</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82245"><a href="https://www.kawowo.com/boxing/">Boxing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82246"><a href="https://www.kawowo.com/cycling/">Cycling</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82247"><a href="https://www.kawowo.com/hockey/">Hockey</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82248"><a href="https://www.kawowo.com/lacrosse/">Lacrosse</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82249"><a href="https://www.kawowo.com/live/">Live</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82251"><a href="https://www.kawowo.com/rowing/">Rowing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82250"><a href="https://www.kawowo.com/netball/">Netball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82252"><a href="https://www.kawowo.com/swimming/">Swimming</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82253"><a href="https://www.kawowo.com/tennis/">Tennis</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110032"><a href="https://www.kawowo.com/american-football/">American Football</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42352"><a href="https://www.kawowo.com/opinion/">Op-eds</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55773"><a>STATS</a><span class="expand-submenu" title="Expand">&#43;</span><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55774"><a href="https://www.kawowo.com/table/2018-19-upl-table/">UPL Table Standings</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55783"><a href="https://www.kawowo.com/calendar/results/">All Results</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55780"><a href="https://www.kawowo.com/calendar/fixtures/">All Fixtures</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78030"><a href="https://www.kawowo.com/list/2018-19uganda-premier-league-top-scorers/">UPL top scorers</a></li></ul></li></ul></div></nav><div id="tetriary" class="left-widget-area" role="complementary"><aside id="ajdg_bnnrwidgets-6" class="widget ajdg_bnnrwidgets"><div class="a-single a-14"><a href="http://clickmeterlink.com/tbet" target="_blank"><img src="https://www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019a.gif" /></a></div></aside></div><div class="site-info"><p>© 2018 Kawowo Sports. All Rights reserved.</p><p>Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p></div></div></div><div class="left-sidebar-bg"></div><div id="bottom-widget" class="widget-area container" role="complementary"><div class="row"><aside id="ajdg_bnnrwidgets-10" class="widget col-xs-12 ajdg_bnnrwidgets"><div class="a-single a-5"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:block"
 data-ad-client="ca-pub-0521644691090227"
 data-ad-slot="9585332407"
 data-ad-format="auto"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside></div></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="site-info"> <a href="https://www.kawowo.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="888" height="250" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kawowo Sports" itemprop="logo" data-attachment-id="21152" data-permalink="https://www.kawowo.com/kww1/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" data-orig-size="888,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Kawowo Sports" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=480%2C135&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=692%2C195&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?w=888&amp;ssl=1 888w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=480%2C135&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=768%2C216&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=722%2C203&amp;ssl=1 722w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=300%2C84&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=128%2C36&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=32%2C9&amp;ssl=1 32w" data-lazy-sizes="(max-width: 888px) 100vw, 888px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a> <a class="kawowo-extra-footer-image" href="http://owinosolutions.com/"><img src="https://www.kawowo.com/wp-content/uploads/2016/11/owino1-e1478170366337.jpg" alt=""></a><p>© 2018 Kawowo Sports. All Rights reserved.</p><p>Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p></div></footer></div> <script type="text/javascript">_sf_async_config.authors = "David Isabirye";
			_sf_async_config.sections = "Golf";
					(function(){
			        function loadChartbeat() {
					window._sf_endpt=(new Date()).getTime();
					var e = document.createElement('script');
					e.setAttribute('language', 'javascript');
					e.setAttribute('type', 'text/javascript');
					e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
					document.body.appendChild(e);
				  }
				  var oldonload = window.onload;
				  window.onload = (typeof window.onload != 'function') ?
					 loadChartbeat : function() { try { oldonload(); } catch (e) { loadChartbeat(); throw e} loadChartbeat(); };
				})();</script> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/www.kawowo.com\/2019\/02\/25\/latest-professional-golfer-deco-mutebi-sets-personal-targets\/":116647};</script> <!--[if lte IE 8]><link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://www.kawowo.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css' type='text/css' media='all' /> <![endif]--> <script type='text/javascript'>var click_object = {"ajax_url":"https:\/\/www.kawowo.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script> <script type='text/javascript'>var localized_strings = {"days":"days","hrs":"hrs","mins":"mins","secs":"secs","previous":"Previous","next":"Next"};</script> <script type='text/javascript'>var kawowo = {"home_page_slider_img_number":"1","loadMoreText":"Load more posts","loadingText":" ","noMorePostsText":"No More Posts","expandText":"Expand","closeText":"Close","startPage":"1","maxPages":"0","nextLink":null,"pagination":"infinite","getTemplateDirectoryUri":"https:\/\/www.kawowo.com\/wp-content\/themes\/kawowo-sports","months":["January","February","March","April","May","June","July","August","September","October","November","December"],"days":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"]};</script> <script type='text/javascript'>var jpfbembed = {"appid":"249643311490","locale":"en_US"};</script> <script type='text/javascript'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.kawowo.com\/wp-admin\/admin-ajax.php","nonce":"3ae69f8a67","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.kawowo.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.kawowo.com%2F2019%2F02%2F25%2Flatest-professional-golfer-deco-mutebi-sets-personal-targets%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":""};</script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});</script> <script type="text/javascript">jQuery(document).ready( function($) {
				$('.sp-header-loaded').prepend( $('.sp-league-menu') );
			} );</script> <script type="text/javascript">jQuery(document).ready( function($) {
				$('.sp-header-loaded').prepend( $('.sp-header-scoreboard') );
			} );</script> <script type="text/javascript" defer src="https://www.kawowo.com/wp-content/cache/autoptimize/js/autoptimize_548c9bf0daf75583b2b1b846cb5a1add.js"></script></body></html>