<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://www.kawowo.com/xmlrpc.php"><link type="text/css" media="all" href="https://www.kawowo.com/wp-content/cache/autoptimize/css/autoptimize_f2fe29a2c928f81fcb984375b8dd4c80.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.kawowo.com/wp-content/cache/autoptimize/css/autoptimize_6c9384f9f8ca4d42a8177fb947fd047b.css" rel="stylesheet" /><title>Teenager Allan Okello arrives in Switzerland prior to trials</title><meta name="description" content="If Allan Okello succeeds in trails at FC Zurich, himself, his representatives, KCCA and the native Lira based Destiny Soccer Academy will smile to the bank with a whooping U.shs 3 Billion in sign on fees."/><link rel="canonical" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Teenager Allan Okello arrives in Switzerland prior to trials" /><meta property="og:description" content="If Allan Okello succeeds in trails at FC Zurich, himself, his representatives, KCCA and the native Lira based Destiny Soccer Academy will smile to the bank with a whooping U.shs 3 Billion in sign on fees." /><meta property="og:url" content="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/" /><meta property="og:site_name" content="Kawowo Sports" /><meta property="article:publisher" content="https://www.facebook.com/kawowosports" /><meta property="article:author" content="https://www.facebook.com/isabirye.david.96" /><meta property="article:section" content="Football" /><meta property="article:published_time" content="2019-05-26T20:46:37+00:00" /><meta property="article:modified_time" content="2019-05-26T23:33:19+00:00" /><meta property="og:updated_time" content="2019-05-26T23:33:19+00:00" /><meta property="og:image" content="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes-1.jpg?fit=900%2C600&#038;ssl=1" /><meta property="og:image:secure_url" content="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes-1.jpg?fit=900%2C600&#038;ssl=1" /><meta property="og:image:width" content="900" /><meta property="og:image:height" content="600" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="If Allan Okello succeeds in trails at FC Zurich, himself, his representatives, KCCA and the native Lira based Destiny Soccer Academy will smile to the bank with a whooping U.shs 3 Billion in sign on fees." /><meta name="twitter:title" content="Teenager Allan Okello arrives in Switzerland prior to trials" /><meta name="twitter:site" content="@KawowoSports" /><meta name="twitter:image" content="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes-1.jpg?fit=900%2C600&#038;ssl=1" /><meta name="twitter:creator" content="@IsabiryeDavid" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.kawowo.com/#organization","name":"Kawowo Sports","url":"https://www.kawowo.com/","sameAs":["https://www.facebook.com/kawowosports","https://www.instagram.com/kawowosports/","https://www.youtube.com/c/Kawowo","https://twitter.com/KawowoSports"],"logo":{"@type":"ImageObject","@id":"https://www.kawowo.com/#logo","url":"https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&ssl=1","width":888,"height":250,"caption":"Kawowo Sports"},"image":{"@id":"https://www.kawowo.com/#logo"}},{"@type":"WebSite","@id":"https://www.kawowo.com/#website","url":"https://www.kawowo.com/","name":"Kawowo Sports","publisher":{"@id":"https://www.kawowo.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.kawowo.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/#webpage","url":"https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/","inLanguage":"en-US","name":"Teenager Allan Okello arrives in Switzerland prior to trials","isPartOf":{"@id":"https://www.kawowo.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/#primaryimage","url":"https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes-1.jpg?fit=900%2C600&ssl=1","width":900,"height":600},"primaryImageOfPage":{"@id":"https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/#primaryimage"},"datePublished":"2019-05-26T20:46:37+00:00","dateModified":"2019-05-26T23:33:19+00:00","description":"If Allan Okello succeeds in trails at FC Zurich, himself, his representatives, KCCA and the native Lira based Destiny Soccer Academy will smile to the bank with a whooping U.shs 3 Billion in sign on fees."},{"@type":"Article","@id":"https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/#article","isPartOf":{"@id":"https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/#webpage"},"author":{"@id":"https://www.kawowo.com/author/david/#author","name":"David Isabirye"},"publisher":{"@id":"https://www.kawowo.com/#organization"},"headline":"Teenager Allan Okello arrives in Switzerland prior to trials","datePublished":"2019-05-26T20:46:37+00:00","dateModified":"2019-05-26T23:33:19+00:00","commentCount":0,"mainEntityOfPage":"https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/#webpage","image":{"@id":"https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/#primaryimage"},"articleSection":"Football"},{"@type":"Person","@id":"https://www.kawowo.com/author/david/#author","name":"David Isabirye","image":{"@type":"ImageObject","@id":"https://www.kawowo.com/#personlogo","url":"https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&d=mm&r=g","caption":"David Isabirye"},"description":"David Isabirye is a senior staff writer for Kawowo Sports where he covers most of the major events.","sameAs":["https://www.facebook.com/isabirye.david.96","https://www.instagram.com/davidisabirye","https://twitter.com/https://twitter.com/IsabiryeDavid"]}]}</script> <link rel='dns-prefetch' href='//s0.wp.com' /><link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Feed" href="https://www.kawowo.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Comments Feed" href="https://www.kawowo.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Kawowo Sports &raquo; Teenager Allan Okello arrives in Switzerland prior to trials Comments Feed" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.6.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-20862137-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-20862137-4', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <link rel='stylesheet' id='dashicons-css'  href='https://www.kawowo.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' /><link crossorigin="anonymous" rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=5.2' type='text/css' media='all' /> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/www.kawowo.com","hash_tracking":"false"};</script> <script type='text/javascript' src='https://www.kawowo.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var wpp_params = {"sampling_active":"1","sampling_rate":"10","ajax_url":"https:\/\/www.kawowo.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"125238","token":"4db58f0782","debug":""};</script> <link rel='https://api.w.org/' href='https://www.kawowo.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.kawowo.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.kawowo.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2" /><meta name="generator" content="SportsPress 2.6.14" /><meta name="generator" content="SportsPress Pro 2.6.14" /><link rel='shortlink' href='https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/' /><link rel="alternate" type="application/json+oembed" href="https://www.kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kawowo.com%2F2019%2F05%2F26%2Fteenager-allan-okello-arrives-in-switzerland-prior-to-trials%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kawowo.com%2F2019%2F05%2F26%2Fteenager-allan-okello-arrives-in-switzerland-prior-to-trials%2F&#038;format=xml" />  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-0521644691090227",
          enable_page_level_ads: true
     });</script> <link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel='dns-prefetch' href='//widgets.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/amp/"><link rel="icon" href="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg?fit=160%2C160&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg?fit=160%2C160&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2016/11/favicon.jpg?fit=160%2C160&#038;ssl=1" /></head><body class="post-template-default single single-post postid-125238 single-format-standard wp-custom-logo group-blog"><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header" role="banner"><nav id="top-navigation" class="navbar-navigation" role="navigation"> <button id="left-navbar-toggle" class="menu-toggle" aria-controls="left-sidebar" aria-expanded="false"><span class="screen-reader-text">Menu</span><svg><path d="M3 6h18v2.016h-18v-2.016zM3 12.984v-1.969h18v1.969h-18zM3 18v-2.016h18v2.016h-18z"></path></svg></button> <button id="navbar-search-toggle" class="search-toggle" aria-controls="search-panel" aria-expanded="false"><span class="screen-reader-text">Search</span><svg><path d="M9.516 14.016q1.875 0 3.188-1.313t1.313-3.188-1.313-3.188-3.188-1.313-3.188 1.313-1.313 3.188 1.313 3.188 3.188 1.313zM15.516 14.016l4.969 4.969-1.5 1.5-4.969-4.969v-0.797l-0.281-0.281q-1.781 1.547-4.219 1.547-2.719 0-4.617-1.875t-1.898-4.594 1.898-4.617 4.617-1.898 4.594 1.898 1.875 4.617q0 2.438-1.547 4.219l0.281 0.281h0.797z"></path></svg></button><div id="search-panel" class="kawowo-search-panel"> <button class="kawowo-search-panel-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button><form role="search" method="get" class="search-form" action="https://www.kawowo.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Type and hit enter" value="" name="s" title="Search for:" /> </label> <input type="submit" class="search-submit" value="Search" /></form></div><div class="menu-logo"> <a href="https://www.kawowo.com/" class="custom-logo-link" rel="home"><img width="888" height="250" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kawowo Sports" data-attachment-id="21152" data-permalink="https://www.kawowo.com/kww1/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" data-orig-size="888,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Kawowo Sports" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=480%2C135&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=722%2C203&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?w=888&amp;ssl=1 888w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=480%2C135&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=768%2C216&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=722%2C203&amp;ssl=1 722w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=300%2C84&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=128%2C36&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=32%2C9&amp;ssl=1 32w" data-lazy-sizes="(max-width: 888px) 100vw, 888px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div><div class="menu-mainmenu-container"><ul id="top-menu" class="menu"><li id="menu-item-42339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42339"><a href="https://www.kawowo.com">Home</a></li><li id="menu-item-42340" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42340"><a href="https://www.kawowo.com/football/">Football</a></li><li id="menu-item-42346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42346"><a href="https://www.kawowo.com/basketball/">Basketball</a></li><li id="menu-item-42347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42347"><a href="https://www.kawowo.com/rugby/">Rugby</a></li><li id="menu-item-42350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42350"><a href="https://www.kawowo.com/motorsport/">Motorsport</a></li><li id="menu-item-42354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.kawowo.com/cricket/">Cricket</a></li><li id="menu-item-42348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42348"><a href="https://www.kawowo.com/athletics/">Athletics</a></li><li id="menu-item-42349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42349"><a href="https://www.kawowo.com/golf/">Golf</a></li><li id="menu-item-42345" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42345"><a>More</a><span class="expand-submenu" title="Expand">&#43;</span><ul class="sub-menu"><li id="menu-item-42351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42351"><a href="https://www.kawowo.com/pool/">Pool</a></li><li id="menu-item-42343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42343"><a href="https://www.kawowo.com/weightlifting/">Weightlifting</a></li><li id="menu-item-42344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42344"><a href="https://www.kawowo.com/volleyball/">Volleyball</a></li><li id="menu-item-82243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82243"><a href="https://www.kawowo.com/chess/">Chess</a></li><li id="menu-item-82244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82244"><a href="https://www.kawowo.com/others/">Others</a></li><li id="menu-item-82245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82245"><a href="https://www.kawowo.com/boxing/">Boxing</a></li><li id="menu-item-82246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82246"><a href="https://www.kawowo.com/cycling/">Cycling</a></li><li id="menu-item-82247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82247"><a href="https://www.kawowo.com/hockey/">Hockey</a></li><li id="menu-item-82248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82248"><a href="https://www.kawowo.com/lacrosse/">Lacrosse</a></li><li id="menu-item-82249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82249"><a href="https://www.kawowo.com/live/">Live</a></li><li id="menu-item-82251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82251"><a href="https://www.kawowo.com/rowing/">Rowing</a></li><li id="menu-item-82250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82250"><a href="https://www.kawowo.com/netball/">Netball</a></li><li id="menu-item-82252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82252"><a href="https://www.kawowo.com/swimming/">Swimming</a></li><li id="menu-item-82253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82253"><a href="https://www.kawowo.com/tennis/">Tennis</a></li><li id="menu-item-110032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110032"><a href="https://www.kawowo.com/american-football/">American Football</a></li></ul></li><li id="menu-item-42352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42352"><a href="https://www.kawowo.com/opinion/">Op-eds</a></li><li id="menu-item-55773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55773"><a>STATS</a><span class="expand-submenu" title="Expand">&#43;</span><ul class="sub-menu"><li id="menu-item-55774" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55774"><a href="https://www.kawowo.com/table/2018-19-upl-table/">UPL Table Standings</a></li><li id="menu-item-55783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55783"><a href="https://www.kawowo.com/calendar/results/">All Results</a></li><li id="menu-item-55780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55780"><a href="https://www.kawowo.com/calendar/fixtures/">All Fixtures</a></li><li id="menu-item-78030" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78030"><a href="https://www.kawowo.com/list/2018-19uganda-premier-league-top-scorers/">UPL top scorers</a></li></ul></li></ul></div></nav></header><div id="content" class="site-content container"><div class="row"><div id="top-ads-widget" class="widget-area col-xs-12" role="complementary"><aside id="text-7" class="widget widget_text"><div class="textwidget"><p><ins data-revive-zoneid="9" data-revive-id="beba77153dbe07400da103c85884534b"></ins><script async src="//batraim.com/ads/www/delivery/asyncjs.php"></script></p></div></aside></div></div><div class="row"><div id="primary" class="content-area col-lg-8"><main id="main" class="site-main row" role="main"><article id="post-125238" class="col-md-12 post-125238 post type-post status-publish format-standard has-post-thumbnail hentry category-football"><header class="entry-header row"><div class="single-header col-xs-12"><div class="category-list"> <a href="https://www.kawowo.com/football/">Football</a></div><h1 class="entry-title">Teenager Allan Okello arrives in Switzerland prior to trials</h1></div><div class="col-xs-12 col-sm-8 col-sm-push-4 col-md-9 col-md-push-3 col-lg-9 col-lg-push-3 col-xl-10 col-xl-push-2"><div class="kawowo-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-125238" class="share-facebook sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-125238" class="share-twitter sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-125238" class="share-linkedin sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div><div class="entry-meta"> <span class="posted-on"><a href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/" rel="bookmark"><time class="entry-date published updated" datetime="2019-05-26T23:46:37+03:00">7 hours</time></a> ago</span><br/><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://www.kawowo.com/author/david/">David Isabirye</a></span></span></div></div><div class='author-avatar-wrapper col-xs-12 col-sm-4 col-sm-pull-8 col-md-3 col-md-pull-9 col-xl-2 col-xl-pull-10'><div class="author-avatar"><img alt src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&#038;d=mm&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" data-lazy-srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=192&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript></div><div class="kawowo-author-social-icons"><a href="https://twitter.com/IsabiryeDavid" title="Twitter" target="_blank"><span class="screen-reader-text">Twitter</span><svg viewBox="0 0 26 28"><path d="M25.312 6.375q-1.047 1.531-2.531 2.609 0.016 0.219 0.016 0.656 0 2.031-0.594 4.055t-1.805 3.883-2.883 3.289-4.031 2.281-5.047 0.852q-4.234 0-7.75-2.266 0.547 0.063 1.219 0.063 3.516 0 6.266-2.156-1.641-0.031-2.938-1.008t-1.781-2.492q0.516 0.078 0.953 0.078 0.672 0 1.328-0.172-1.75-0.359-2.898-1.742t-1.148-3.211v-0.063q1.062 0.594 2.281 0.641-1.031-0.688-1.641-1.797t-0.609-2.406q0-1.375 0.688-2.547 1.891 2.328 4.602 3.727t5.805 1.555q-0.125-0.594-0.125-1.156 0-2.094 1.477-3.57t3.57-1.477q2.188 0 3.687 1.594 1.703-0.328 3.203-1.219-0.578 1.797-2.219 2.781 1.453-0.156 2.906-0.781z"></path></svg></a><a href="https://www.facebook.com/isabirye.david.96" title="Facebook" target="_blank"><span class="screen-reader-text">Facebook</span><svg viewBox="0 0 16 28"><path d="M14.984 0.187v4.125h-2.453q-1.344 0-1.813 0.562t-0.469 1.687v2.953h4.578l-0.609 4.625h-3.969v11.859h-4.781v-11.859h-3.984v-4.625h3.984v-3.406q0-2.906 1.625-4.508t4.328-1.602q2.297 0 3.563 0.187z"></path></svg></a><a href="https://www.instagram.com/davidisabirye" title="Instagram" target="_blank"><span class="screen-reader-text">Instagram</span><svg viewBox="0 0 24 28"><path d="M21.281 22.281v-10.125h-2.109q0.313 0.984 0.313 2.047 0 1.969-1 3.633t-2.719 2.633-3.75 0.969q-3.078 0-5.266-2.117t-2.188-5.117q0-1.062 0.313-2.047h-2.203v10.125q0 0.406 0.273 0.68t0.68 0.273h16.703q0.391 0 0.672-0.273t0.281-0.68zM16.844 13.953q0-1.937-1.414-3.305t-3.414-1.367q-1.984 0-3.398 1.367t-1.414 3.305 1.414 3.305 3.398 1.367q2 0 3.414-1.367t1.414-3.305zM21.281 8.328v-2.578q0-0.438-0.313-0.758t-0.766-0.32h-2.719q-0.453 0-0.766 0.32t-0.313 0.758v2.578q0 0.453 0.313 0.766t0.766 0.313h2.719q0.453 0 0.766-0.313t0.313-0.766zM24 5.078v17.844q0 1.266-0.906 2.172t-2.172 0.906h-17.844q-1.266 0-2.172-0.906t-0.906-2.172v-17.844q0-1.266 0.906-2.172t2.172-0.906h17.844q1.266 0 2.172 0.906t0.906 2.172z"></path></svg></a></div></div></header><div class="row"><div class="entry-content col-xs-12 col-lg-10 col-lg-push-2"><figure class="wp-block-image"><img data-attachment-id="118471" data-permalink="https://www.kawowo.com/jb-allan-okello-uganda-cranes/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?fit=900%2C600&amp;ssl=1" data-orig-size="900,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="jb-allan-okello-uganda-cranes" data-image-description data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?fit=480%2C320&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?fit=692%2C461&amp;ssl=1" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?w=692&#038;ssl=1" alt class="wp-image-118471 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?w=900&amp;ssl=1 900w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=480%2C320&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=128%2C85&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=32%2C21&amp;ssl=1 32w" data-lazy-sizes="(max-width: 692px) 100vw, 692px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?w=692&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="118471" data-permalink="https://www.kawowo.com/jb-allan-okello-uganda-cranes/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?fit=900%2C600&amp;ssl=1" data-orig-size="900,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="jb-allan-okello-uganda-cranes" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?fit=480%2C320&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?fit=692%2C461&amp;ssl=1" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?w=692&#038;ssl=1" alt="" class="wp-image-118471" srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?w=900&amp;ssl=1 900w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=480%2C320&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=128%2C85&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/03/jb-allan-okello-uganda-cranes.jpg?resize=32%2C21&amp;ssl=1 32w" sizes="(max-width: 692px) 100vw, 692px" data-recalc-dims="1" /></noscript><figcaption>Allan Okello in national team colours during the Kampala region tour game. Okello scored (PHOTO: John Batanudde)</figcaption></figure><p class="has-drop-cap"><strong>Exciting Ugandan left footed teenage attacker Allan &#8220;Jolly&#8221; Okello is in Zurich city, Switzerland ahead of a week-long trial stint with top tier outfit Fussballclub Zürich, popularly known as FC Zurich.</strong></p><p>FC Zurich has been a keen follower of
the talented youngster since he featured in the COSAFA U-20 tournament hosted
by Zambia in 2017, through to the CAF Champions and Confederation Cup
tournaments as well as his matches in the domestic Uganda Premier League.</p><p>Okello, a player current contracted with the 13 time Uganda Premier League champions Kampala Capital City Authority (KCCA) has been phenomenal since graduating from the club’s academy side.</p><div class="g g-1"><div class="g-single a-14"><a href="http://clickmeterlink.com/tbet" target="_blank"><img src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019a.gif?w=692&#038;ssl=1" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019a.gif?w=692&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019a.gif?w=692&#038;ssl=1" data-recalc-dims="1" /></noscript></a></div></div><p>A few weeks ago, <a href="https://www.kawowo.com/2019/05/11/kcca-play-maker-okello-departs-for-greener-pastures-kizza-returns/" target="_blank" rel="noreferrer noopener" aria-label="Okello traveled to Nairobi for his visa to Switzerland (opens in a new tab)">Okello traveled to Nairobi for his visa to Switzerland</a> which he successfully secured before returning to play for his native Lango Province, scoring a hat-trick and he been since training with the national team preparing for the 2019 African Cup of Nations in Egypt.</p><p>He was then dropped from the team preparing for AFCON and selected to be among 2019 COSAFA bound contingent until Thursday when he pulled out as the invitation letter from Fussballclub Zürich was finally received.</p><p>He left Entebbe International Airport
in the wee-hours of Sunday, 26<sup>th</sup> May 2019.</p><div class="g g-4"><div class="g-single a-9"><a href="http://bit.ly/2PdzYbH"target="_blank"><img src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_loyalty_bonus_16052019.gif?w=692&#038;ssl=1" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_loyalty_bonus_16052019.gif?w=692&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_loyalty_bonus_16052019.gif?w=692&#038;ssl=1" data-recalc-dims="1" /></noscript></a></div></div><p>There was a stop-over at Aturtuk Airport,
Istanbul in Turkey at 9:30 AM before setting off by noon to the final
destination.</p><p>Okello successfully touched down Zurich at 2:20pm where he was received by the sporting director who is also chief scout Adamson Fahad.</p><div class="wp-block-image"><figure class="aligncenter"><img data-attachment-id="125239" data-permalink="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/allan-okello-with-adamson-fahad/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=887%2C1516&amp;ssl=1" data-orig-size="887,1516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Allan-Okello-with-Adamson-Fahad" data-image-description data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=480%2C820&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=351%2C600&amp;ssl=1" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=351%2C600&amp;ssl=1" alt class="wp-image-125239 jetpack-lazy-image" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?w=887&amp;ssl=1 887w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=480%2C820&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=768%2C1313&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=351%2C600&amp;ssl=1 351w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=176%2C300&amp;ssl=1 176w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=75%2C128&amp;ssl=1 75w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=19%2C32&amp;ssl=1 19w" data-lazy-sizes="(max-width: 692px) 100vw, 692px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=351%2C600&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="125239" data-permalink="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/allan-okello-with-adamson-fahad/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=887%2C1516&amp;ssl=1" data-orig-size="887,1516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Allan-Okello-with-Adamson-Fahad" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=480%2C820&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=351%2C600&amp;ssl=1" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?fit=351%2C600&amp;ssl=1" alt="" class="wp-image-125239" srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?w=887&amp;ssl=1 887w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=480%2C820&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=768%2C1313&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=351%2C600&amp;ssl=1 351w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=176%2C300&amp;ssl=1 176w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=75%2C128&amp;ssl=1 75w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Allan-Okello-with-Adamson-Fahad.jpg?resize=19%2C32&amp;ssl=1 19w" sizes="(max-width: 692px) 100vw, 692px" /></noscript><figcaption>Allan Okello with Adamson moments after arrival in Zurich on Sunday</figcaption></figure></div><p>Adamson has recently succeeded with
the sale of Angola captain Michael Bastos to Italian Serie A side FC Lazio.</p><p>The entire deal for Okello has been
engineered by Real Stars Sports Agency in conjunction with his agent Mwesigwa.</p><p>Okello is expected to start training on
Monday, 27<sup>th</sup> May 2019.</p><p>He will also be subjected to play two trial matches on 29<sup>th</sup> and 31<sup>st</sup> May before returning to Uganda on 1<sup>st</sup> June 2019.</p><p>If all goes well and the move is blessed, Okello, his representatives, the parent club (KCCA) and the native Lira based academy Destiny Soccer Academy will smile to the bank with a whooping U.shs 3 Billion in sign on fees.</p><p>A host of clubs across the globe have
been over the years being interested in his services.</p><p>From <a href="https://www.kawowo.com/2017/07/12/kcca-allan-okello-to-join-dutch-ajax-amsterdam/" target="_blank" rel="noreferrer noopener" aria-label="Dutch side Ajax Amsterdam (opens in a new tab)">Dutch side Ajax Amsterdam</a>, clubs in Eastern Europe, Mamelodi Sundowns, Zamalek, Al Ahly to clubs within the CECAFA region, Okello remains one of the most sought after item.</p><p>Back, his agent was cleared that such <a href="https://www.kawowo.com/2017/07/14/offers-allan-okello-will-accepted-level-studies-says-agent/" target="_blank" rel="noreferrer noopener" aria-label="offers would be considered after Okello had completed the 'A' level education (opens in a new tab)">offers would be considered after Okello had completed the &#8216;A&#8217; level education</a>.</p><p>Now that school is long done and dusted, Okello has matured in physic and mental strength, could this be the right timing for the best offer?</p><figure class="wp-block-image"><img data-attachment-id="112193" data-permalink="https://www.kawowo.com/jb-allan-okello-kcca/" data-orig-file="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?fit=900%2C600&amp;ssl=1" data-orig-size="900,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="jb-allan-okello&#8211;kcca" data-image-description data-medium-file="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?fit=480%2C320&amp;ssl=1" data-large-file="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?fit=692%2C461&amp;ssl=1" src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?w=692&#038;ssl=1" alt class="wp-image-112193 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=32%2C21&amp;ssl=1 32w" data-lazy-sizes="(max-width: 692px) 100vw, 692px" data-lazy-src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?w=692&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="112193" data-permalink="https://www.kawowo.com/jb-allan-okello-kcca/" data-orig-file="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?fit=900%2C600&amp;ssl=1" data-orig-size="900,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="jb-allan-okello&#8211;kcca" data-image-description="" data-medium-file="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?fit=480%2C320&amp;ssl=1" data-large-file="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?fit=692%2C461&amp;ssl=1" src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?w=692&#038;ssl=1" alt="" class="wp-image-112193" srcset="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/www.kawowo.com/wp-content/uploads/2018/12/jb-allan-okello-kcca.jpg?resize=32%2C21&amp;ssl=1 32w" sizes="(max-width: 692px) 100vw, 692px" data-recalc-dims="1" /></noscript><figcaption>Allan Okello celebrates a goal for KCCA</figcaption></figure><p><strong>About
FC Zurich:</strong></p><p>Fussballclub Zürich plays in the
Swiss top flight premier League managed by former Swiss left back Ludovic
Magnin.</p><p>&nbsp;The club has a rich history, having been
founded in 1896.</p><p>They have won the Swiss Super League
12 times and the Swiss Cup 10 times.</p><p>The club won the 2009 Swiss Super
League and last won the Swiss Cup in 2018.</p><p>Letzigrund Stadium in Zürich, a 26,104
sitter facility hosts their home matches.</p><p>Since 2011 season to date, they are a
regular club at the UEFA Europa competition.</p><p><strong>Who is Allan Okello?</strong></p><p><strong>Full Names:</strong>&nbsp;Allan Okello</p><p><strong>Nick Name</strong>: Jolly</p><p><strong>Date of Birth:</strong>&nbsp;4th July 2000</p><p><strong>Parents:</strong>&nbsp;Patrick Ojom (Deceased) &amp; Joan Agomu</p><p><strong>Place of Birth</strong>: Lira Town</p><p><strong>Education:</strong>&nbsp;St Kizito Nursery and Primay School, Kibuli S.S</p><p><strong>Strong Foot</strong>: Left</p><p><strong>Inspired by:</strong>&nbsp;Bob Obira, former footballer with Boroboro F.C, KCCA F.C &amp; Express F.C</p><p><strong>Football Success:</strong>&nbsp; Uganda Premier League winner (2016/17, 2018/19), Uganda Cup winner (2017/18), Winner National Post Primary Championship with Kibuli S.S (2014), Winner – ARS Northern Region (With Lira’s Destiny Sports Academy), MVP Airtel Rising Stars (2014, 2015, 2016), Copa Cocacola M.V.P (2016), FUFA Junior League M.V.P (2016), Young Player of the Year (2016–2017), Airtel FUFA Best eleven (2017–2018), Airtel FUFA fans’ favourite player of the year (2018)</p><p><strong>Role Models:</strong>&nbsp;Geofrey Massa and Stephen Bengo (in Uganda), Ozil and Xavi (Elsewhere)</p></div><footer class="entry-footer col-xs-12"><div class="kawowo-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-125238" class="share-facebook sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-125238" class="share-twitter sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-125238" class="share-linkedin sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.kawowo.com/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></footer></div></article><div class="kawowo-related-posts col-md-12"><h3><span>You May Also Like</span></h3><div class="row"><div class="col-xs-12 col-md-4"> <a class="related-posts-thumbnail" href="https://www.kawowo.com/2019/05/26/onyango-donates-to-kenzos-big-talent-soccer-academy/" title="Onyango donates to Kenzo’s Big Talent Soccer Academy" style="background: url( https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Onyango-Kenzo.jpg?fit=480%2C320&#038;ssl=1 ) center no-repeat;background-size: cover;"></a><p><a href="https://www.kawowo.com/2019/05/26/onyango-donates-to-kenzos-big-talent-soccer-academy/" title="Onyango donates to Kenzo’s Big Talent Soccer Academy">Onyango donates to Kenzo’s Big Talent Soccer Academy</a></p></div><div class="col-xs-12 col-md-4"> <a class="related-posts-thumbnail" href="https://www.kawowo.com/2019/05/26/2019-afcon-countdown-26-days-players-with-most-appearances/" title="2019 AFCON Countdown (26 Days): Players with most appearances" style="background: url( https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/05/rigobert-song.jpg?fit=480%2C320&#038;ssl=1 ) center no-repeat;background-size: cover;"></a><p><a href="https://www.kawowo.com/2019/05/26/2019-afcon-countdown-26-days-players-with-most-appearances/" title="2019 AFCON Countdown (26 Days): Players with most appearances">2019 AFCON Countdown (26 Days): Players with most appearances</a></p></div><div class="col-xs-12 col-md-4"> <a class="related-posts-thumbnail" href="https://www.kawowo.com/2019/05/26/airtel-masaza-cup-busiro-boosted-by-wakiso-giants-support/" title="Airtel Masaza Cup: Busiro boosted by Wakiso Giants support" style="background: url( https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?fit=480%2C320&#038;ssl=1 ) center no-repeat;background-size: cover;"></a><p><a href="https://www.kawowo.com/2019/05/26/airtel-masaza-cup-busiro-boosted-by-wakiso-giants-support/" title="Airtel Masaza Cup: Busiro boosted by Wakiso Giants support">Airtel Masaza Cup: Busiro boosted by Wakiso Giants support</a></p></div></div></div><div id="comments" class="comments-area col-md-12"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/05/26/teenager-allan-okello-arrives-in-switzerland-prior-to-trials/#respond" style="display:none;">Cancel reply</a></small></span></h3><form action="https://www.kawowo.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" rows="1" aria-required="true" required="required" placeholder="Comment" ></textarea></p><div class="comment-fields"><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" aria-required="true" required="required" placeholder="Name" /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" aria-required="true" required="required" placeholder="Email" /></p><p class="comment-form-ur"><label for="url">Website</label> <input id="url" name="url" type="url" value="" placeholder="Website" /></p></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='125238' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p></form></div></div></main></div><div id="secondary" class="widget-area col-lg-4" role="complementary"><div class="theiaStickySidebar"><aside id="text-8" class="widget widget_text"><div class="textwidget"><p><a href="http://clickmeterlink.com/tbet" target="_blank" rel="noopener noreferrer"><img src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019b.gif?w=692&#038;ssl=1" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019b.gif?w=692&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/01/topbet_web_15012019b.gif?w=692&#038;ssl=1" data-recalc-dims="1" /></noscript></a></p></div></aside><aside id="text-6" class="widget widget_text"><div class="textwidget"><p><a href="http://bit.ly/2PdzYbH" target="_blank" rel="noopener noreferrer"><img src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_refer_friend_16052019.gif?w=692&#038;ssl=1" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_refer_friend_16052019.gif?w=692&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_refer_friend_16052019.gif?w=692&#038;ssl=1" data-recalc-dims="1" /></noscript></a></p></div></aside><aside id="wpp-3" class="widget popular-posts"><h2 class="widget-title"><span>Trending</span></h2><ul class="fat-wpp-list"><li><div class="fat-wpp-image"><a href="https://www.kawowo.com/2019/05/26/airtel-masaza-cup-busiro-boosted-by-wakiso-giants-support/" title="Airtel Masaza Cup: Busiro boosted by Wakiso Giants support"><img width="480" height="320" src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?fit=480%2C320&amp;ssl=1" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="125188" data-permalink="https://www.kawowo.com/2019/05/26/airtel-masaza-cup-busiro-boosted-by-wakiso-giants-support/busiro/" data-orig-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?fit=900%2C600&amp;ssl=1" data-orig-size="900,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Busiro" data-image-description="" data-medium-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?fit=480%2C320&amp;ssl=1" data-large-file="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?fit=692%2C461&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?w=900&amp;ssl=1 900w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?resize=480%2C320&amp;ssl=1 480w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?resize=128%2C85&amp;ssl=1 128w, https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?resize=32%2C21&amp;ssl=1 32w" data-lazy-sizes="(max-width: 480px) 100vw, 480px" data-lazy-src="https://i1.wp.com/www.kawowo.com/wp-content/uploads/2019/05/Busiro.jpg?fit=480%2C320&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><div class="fat-wpp-image-cat"><a href="https://www.kawowo.com/football/">Football</a></div></div><h2 class="entry-title"><a href="https://www.kawowo.com/2019/05/26/airtel-masaza-cup-busiro-boosted-by-wakiso-giants-support/" title="Airtel Masaza Cup: Busiro boosted by Wakiso Giants support">Airtel Masaza Cup: Busiro boosted by Wakiso Giants support</a></h2></li></ul></aside></div></div></div></div><div id="left-sidebar" class="left-sidebar-area"><div class="left-sidebar-content"><div class="left-header"><div class="left-logo"> <a href="https://www.kawowo.com/" class="custom-logo-link" rel="home"><img width="888" height="250" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kawowo Sports" data-attachment-id="21152" data-permalink="https://www.kawowo.com/kww1/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" data-orig-size="888,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Kawowo Sports" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=480%2C135&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=692%2C195&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?w=888&amp;ssl=1 888w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=480%2C135&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=768%2C216&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=722%2C203&amp;ssl=1 722w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=300%2C84&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=128%2C36&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=32%2C9&amp;ssl=1 32w" data-lazy-sizes="(max-width: 888px) 100vw, 888px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a> <button class="left-sidebar-close" title="Close"><svg><line stroke-miterlimit="10" x1="0.354" y1="0.354" x2="14.354" y2="14.354"/><line stroke-miterlimit="10" x1="14.354" y1="0.354" x2="0.354" y2="14.354"/></svg></button></div></div><nav id="site-navigation" class="main-navigation" role="navigation"><div class="menu-mainmenu-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42339"><a href="https://www.kawowo.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42340"><a href="https://www.kawowo.com/football/">Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42346"><a href="https://www.kawowo.com/basketball/">Basketball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42347"><a href="https://www.kawowo.com/rugby/">Rugby</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42350"><a href="https://www.kawowo.com/motorsport/">Motorsport</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42354"><a href="https://www.kawowo.com/cricket/">Cricket</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42348"><a href="https://www.kawowo.com/athletics/">Athletics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42349"><a href="https://www.kawowo.com/golf/">Golf</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42345"><a>More</a><span class="expand-submenu" title="Expand">&#43;</span><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42351"><a href="https://www.kawowo.com/pool/">Pool</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42343"><a href="https://www.kawowo.com/weightlifting/">Weightlifting</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42344"><a href="https://www.kawowo.com/volleyball/">Volleyball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82243"><a href="https://www.kawowo.com/chess/">Chess</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82244"><a href="https://www.kawowo.com/others/">Others</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82245"><a href="https://www.kawowo.com/boxing/">Boxing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82246"><a href="https://www.kawowo.com/cycling/">Cycling</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82247"><a href="https://www.kawowo.com/hockey/">Hockey</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82248"><a href="https://www.kawowo.com/lacrosse/">Lacrosse</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82249"><a href="https://www.kawowo.com/live/">Live</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82251"><a href="https://www.kawowo.com/rowing/">Rowing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82250"><a href="https://www.kawowo.com/netball/">Netball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82252"><a href="https://www.kawowo.com/swimming/">Swimming</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82253"><a href="https://www.kawowo.com/tennis/">Tennis</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110032"><a href="https://www.kawowo.com/american-football/">American Football</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42352"><a href="https://www.kawowo.com/opinion/">Op-eds</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55773"><a>STATS</a><span class="expand-submenu" title="Expand">&#43;</span><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55774"><a href="https://www.kawowo.com/table/2018-19-upl-table/">UPL Table Standings</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55783"><a href="https://www.kawowo.com/calendar/results/">All Results</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55780"><a href="https://www.kawowo.com/calendar/fixtures/">All Fixtures</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78030"><a href="https://www.kawowo.com/list/2018-19uganda-premier-league-top-scorers/">UPL top scorers</a></li></ul></li></ul></div></nav><div id="tetriary" class="left-widget-area" role="complementary"><aside id="text-9" class="widget widget_text"><div class="textwidget"><p><a href="http://bit.ly/2PftsS4" target="_blank" rel="noopener noreferrer"><img src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_refer_friend_16052019.gif?w=692&#038;ssl=1" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_refer_friend_16052019.gif?w=692&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/www.kawowo.com/wp-content/uploads/2019/05/ubet_refer_friend_16052019.gif?w=692&#038;ssl=1" data-recalc-dims="1" /></noscript></a></p></div></aside></div><div class="site-info"><p>© 2018 Kawowo Sports. All Rights reserved.</p><p>Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p></div></div></div><div class="left-sidebar-bg"></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="site-info"> <a href="https://www.kawowo.com/" class="custom-logo-link" rel="home"><img width="888" height="250" src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kawowo Sports" data-attachment-id="21152" data-permalink="https://www.kawowo.com/kww1/" data-orig-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1" data-orig-size="888,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Kawowo Sports" data-image-description="" data-medium-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=480%2C135&amp;ssl=1" data-large-file="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=692%2C195&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?w=888&amp;ssl=1 888w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=480%2C135&amp;ssl=1 480w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=768%2C216&amp;ssl=1 768w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=722%2C203&amp;ssl=1 722w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=300%2C84&amp;ssl=1 300w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=128%2C36&amp;ssl=1 128w, https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?resize=32%2C9&amp;ssl=1 32w" data-lazy-sizes="(max-width: 888px) 100vw, 888px" data-lazy-src="https://i0.wp.com/www.kawowo.com/wp-content/uploads/2016/11/kww1.png?fit=888%2C250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a> <a class="kawowo-extra-footer-image" href="http://owinosolutions.com/"><img src="https://www.kawowo.com/wp-content/uploads/2016/11/owino1-e1478170366337.jpg" alt=""></a><p>© 2018 Kawowo Sports. All Rights reserved.</p><p>Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p></div></footer></div> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/www.kawowo.com\/2019\/05\/26\/teenager-allan-okello-arrives-in-switzerland-prior-to-trials\/":125238};</script> <script type='text/javascript'>var click_object = {"ajax_url":"https:\/\/www.kawowo.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script> <script type='text/javascript'>var localized_strings = {"days":"days","hrs":"hrs","mins":"mins","secs":"secs","previous":"Previous","next":"Next"};</script> <script type='text/javascript'>var kawowo = {"home_page_slider_img_number":"1","loadMoreText":"Load more posts","loadingText":" ","noMorePostsText":"No More Posts","expandText":"Expand","closeText":"Close","startPage":"1","maxPages":"0","nextLink":null,"pagination":"infinite","getTemplateDirectoryUri":"https:\/\/www.kawowo.com\/wp-content\/themes\/kawowo-sports","months":["January","February","March","April","May","June","July","August","September","October","November","December"],"days":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"]};</script> <script type='text/javascript'>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.kawowo.com\/wp-admin\/admin-ajax.php","nonce":"fad1212f1f","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.kawowo.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.kawowo.com%2F2019%2F05%2F26%2Fteenager-allan-okello-arrives-in-switzerland-prior-to-trials%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":""};</script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});</script> <script type="text/javascript">jQuery(document).ready( function($) {
				$('.sp-header-loaded').prepend( $('.sp-league-menu') );
			} );</script> <script type="text/javascript">jQuery(document).ready( function($) {
				$('.sp-header-loaded').prepend( $('.sp-header-scoreboard') );
			} );</script> <script type="text/javascript" defer src="https://www.kawowo.com/wp-content/cache/autoptimize/js/autoptimize_157e7db3bf9df8ebf57de33111686550.js"></script></body></html>
<!-- Dynamic page generated in 0.423 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-05-27 06:48:15 -->

<!-- Compression = gzip -->